[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian hangs randomly

On Mon, Aug 06, 2007 at 12:27:44PM +0200, Jogito nit wrote:
> First of all, sorry about my english.

No problem.

> I have a problem with my Debian, it hangs randomly. I have tried to
> change the driver of my ati, I, ve tried without 3D acceleration. I
> thougth that was the memory, so i changed it, but it continue hang.
> When it hangs i cant do anything, no mouse, no keyboard. I?ve tried
> Kubuntu and Knoppix too, and the same problem. I?ve looked the logs
> and i cant find anything strange. In windows i dont have this problem.
> Can someone help me please.
> I ussually use Kubuntu, but I?ve tested Debian to see if the problem
> happend, and of course it happends. So its not a problem of Debian I
> know, but i dont know what can i do, because i dont want to use
> windows. I have tested debian 4 etch, with kernel 2.6.18.
> About 4 years ago i used mandrake, and I had a problem like that
> because the micro heat to much and the kernel try to reduce the
> frequency, so it hang, but I?m not sure of this, I dont know if this
> can help.
> My computer is :
> P4 3,06 HT Ati radeon 9700 Sound blaster live.  1024mb memory.

It sounds like we need to narrow down the source of the troubles.  The
first big dividing line is between a text-based system and an Xwindow
based system.

I'll assume that when you boot your machine normally, it gives you an
Xwindow login.

Reboot the computer but select the single-user mode grub menu option.
If you happen to be using lilo, what you want is the linux s option
(the s is passed to init).  This tells init to boot into single-user
mode.  Debian will boot but instead of giving you X, you will be
prompted for the root password and given a shell.

Now disable the display manager (gdm, kdm, xdm) in /etc/rc2.d
See the README in that directory for instructions for how to do this.

This will mean that when you boot normally, you will get a command-line
login.  To start X from the command line, you type 'startx'.

#shutdown -r now

will cause the computer to boot nomally now (out of single-user mode)
and you should be in text mode.

Try doing some things and see if the computer hangs.  While I wouldn't
touch the package management incase of a hang in the middle, you can use
whatever other text-based apps you have.  Try an editor, lynx or links2
or mc if you have it.  Try the following to exersize the system a bit
(don't worry about 'permission denied', you're only trying to read
files and you don't care about the output.

cd /;du
find /
find / |xargs md5sum

If it doesn't hang by the time it usually would, then we're on the right
track.  If it hangs, try to find out what it was doing.  Also, the first
boot after a hang, look at /var/log/syslog.

If it doesn't hang, you can run apt-get memtest86+.  This should add a
line to your grub menu whereby you can run memtest without an OS loaded.
You can also apt-get lynx and mc so you have some command-line apps to
use while you figure out why the box hangs.

Let us know how things go.  Good luck,


Reply to: