[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: CUPS: unable to configure printer

On 7/28/07, Ken Irving <fnkci@uaf.edu> wrote:
On Fri, Jul 27, 2007 at 10:16:28PM -0800, Ken Irving wrote:
> On Fri, Jul 27, 2007 at 11:18:26PM -0500, Russell L. Harris wrote:
> > * Thomas Beresford <tom.beresford@gmail.com > [070727 22:49]:
> > >    Hello,
> > >
> > >    I tried to setup my HP PSC 1315 printer today on my Debian Etch running
> > >    CUPS 1.2.12. So I used hp-setup to configure my printer and it was all
> > >    right, but when I tried to configure its parameters at the CUPS admin
> > >    page, it asked for a user/password, and I used my root username/password
> > >    but it didn't work for my surprise.
> >
> > "...my my root username/password..." ???  The username of root is "root".
> >
> > On my system, this works:
> >
> >     username:  root
> >     password:  the_password_of_root
> I'm unable to find where this is documented, but add your user to the
> 'lpadmin' group, and you can use your regular user password for the cups
> admin web pages.

Still looking...

  $ zless cupsys-common/changelog.Debian.gz
    CUPS SystemGroup is 'lpadmin'. You need to add users who are allowed
    to add/modify/remove printers/jobs/classes.

Ken Irving, fnkci@uaf.edu

I can't believe this but I finally found what was the problem. The problem was the root password (and my regular user password too), because they had special characters that for some reason didn't work inside firefox, although these characters can be typed correctly (probably it's a encoding problem). I changed the root password for another one that doesn't use special characters and bingo, it worked.

Anyway, I wish I could add a different user and password since I don't want to change my current passwords, but lppasswd still doesn't work because of the "permission denied" problem that I mentioned before. Do I really have to use the same user/password of my linux system into CUPS?

Reply to: