[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Error trying to run apt-get

On Mon, Jul 02, 2007 at 01:00:58AM -0000, Adam wrote:
> Was wondering if anyone has a workaround for this problem other than
> uninstalling and reinstalling.  I'm trying to upgrade a package and
> get this error.  The software involved doesn't seem to be one that I
> can uninstall without uninstalling a bunch of things I'd rather not
> uninstall to reinstall.  See error at the bottom of this upgrade
> command.  The same happens when I just try an install.  Any ideas
> would be greatly appreciated.  I've tried to touch a 777 file for /usr/
> sbin/add-shell but I still get that error.  I pretty much can't run
> any upgrade, I get the same error.  I try the upgrade by itself then
> on debianutils.
> # uname -a
> Linux xena 2.6.7-1-386 #1 Thu Jul 8 05:08:04 EDT 2004 i686 GNU/Linux

2.6.7 is somewhat old now, but should be OK...

Which release are you running? Feels like sarge...

> # apt-get upgrade
> Reading Package Lists... Done
> Building Dependency Tree... Done
> The following packages have been kept back:

[snip lots of apt-get output]

> Need to get 0B/37.8MB of archives.
> After unpacking 16.0MB of additional disk space will be used.
> Do you want to continue? [Y/n] Y
> Extracting templates from packages: 100%
> Preconfiguring packages ...
> (Reading database ... 38049 files and directories currently
> installed.)
> Preparing to replace debianutils 2.8.4 (using .../
> debianutils_2.21_i386.deb) ...
> Unpacking replacement debianutils ...
> dpkg: error processing /var/cache/apt/archives/
> debianutils_2.21_i386.deb (--unpack):
>  trying to overwrite `/usr/sbin/add-shell', which is also in package
> passwd
> dpkg-deb: subprocess paste killed by signal (Broken pipe)
> Errors were encountered while processing:
>  /var/cache/apt/archives/debianutils_2.21_i386.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)

The debianutils and passwd packages both contain the file 
/usr/sbin/add-shell, which is what the package manager complains about.

This is not a permissions problem - but the package manager complaining.

Looks like a bug in either debianutils or passwd: Debian policy says 
that if they want to have the same file, they should declare that they 
conflict with eachother. Or at least one of them should declare that.

You might get somewhere with:
    apt-get install passwd

to upgrade the passwd package first - the current passwd package in etch 
does not supply that file (but depends on debianutils which in turn does 
supply it...)

Hope this helps

Karl E. Jorgensen
karl@jorgensen.org.uk  http://www.jorgensen.org.uk/
karl@jorgensen.com     http://karl.jorgensen.com
==== Today's fortune:
The default Magic Word, "Abracadabra", actually is a corruption of the
Hebrew phrase "ha-Bracha dab'ra" which means "pronounce the blessing".

Attachment: signature.asc
Description: Digital signature

Reply to: