[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: tv-out, nvidia

Florian Kulzer on 30/04/07 20:59, wrote:
On Mon, Apr 30, 2007 at 20:33:27 +0100, Adam Hardy wrote:
Don Hayward on 26/04/07 16:25, wrote:
On Thu, 26 Apr 2007, Adam Hardy wrote:
I've got a hot nvidia 7950GT GPU which is supported by nvidia's latest driver 1.0-9755. It's running with a TV in my living room.

As for the screen size, I think I've got the xorg.conf set up as perfect as it can be [snipped]
after help from people here, I have got further, but only to the point where X will only load if I disable the glx module.

I think that is normal since the proprietary nvidia driver contains its
own GLX implementation. The installation instructions explicitly state
that you should comment out the normal glx module.

Do you encounter any problems if you start X with the nvidia driver and
the glx module commented out?  You can run "glxinfo | grep direct" to
check. If you get "direct rendering: Yes" then you are all set.

A belated thanks for the input (sorry for the long delay - started a new job and everything got a bit hectic).

I now have colour, thanks to Andre, but things are no clearer on the glx front.

glxinfo initially segfaulted when I tried to run it.

So it seems that glx isn't working though. glxinfo outputs

Error: unable to open display (null)

and the Xorg log contains the failure:

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NvAGP" "3"
(**) NVIDIA(0): Option "TVStandard" "PAL-I"
(**) NVIDIA(0): Option "TVOutFormat" "SVIDEO"
(**) NVIDIA(0): Option "TVOverScan" "0.6"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): Forcing SVIDEO output
(**) NVIDIA(0): TV Standard string: "PAL-I"
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
(EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
(EE) NVIDIA(0):     you continue to encounter problems, Please try
(EE) NVIDIA(0):     reinstalling the NVIDIA driver.
(II) NVIDIA(0): NVIDIA GPU GeForce 7950 GT at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS:
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 7950 GT at PCI:1:0:0:
(--) NVIDIA(0):     NVIDIA TV Encoder (TV-0)
(--) NVIDIA(0): NVIDIA TV Encoder (TV-0): 400.0 MHz maximum pixel clock
(--) NVIDIA(0): TV encoder: NVIDIA

but then further down:

(II) NVIDIA(0): Setting mode "800x600"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture

This is with "load glx" commented out in the xorg.conf - needless to say I have tried re-installing the nvidia driver, but not having changed anything else deliberately, I am not surprised it had no effect.

Do you think X is mistakenly trying to load glx independently and failing, or has it succeeded and glxinfo is just having problems of its own?


Reply to: