[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Lost Internet Access

Well I figured it out after having tried to re-install Etch 5 times ....

In the end it had nothing to do with poor old, much maligned Etch ... and
yet it was only he that had a problem ... the other five Win Xp boxes on my
LAN must just be either too stupid or very very smart ... I have more
comments below for those that want the details about my day from hell trying
everything to get Internet access back up ... but the short answer is that
after the power outage, that seemed to be the cause of my problem, my main
DSL router retained it's settings and it's DHCP server came back as it
should, howver the second DSL router lost it's settings and came back up
with factory defaults ... both routers are LinkSys, so both came up as IP
address and both came up with DHCP enabled !!! Now here is the
freaky thing, ALL of the Win Xp boxes grabbed an address from the main
router and thus could get access to the Internet ONLY Etch grabbed an IP
address from the second router and thus could not access the Internet
because there is no DSL line connected to the second router. Because both
routers are LinkSys they both show the same as the gateway
address. I have now re-configured the second router, disabled the DHCP and
!!!!! Yeah.

Thanks for all the suggestions and help ... and while no one could have
guessed this problem from the info I sent it was one of Andrew's comments
that made me try something that solved the problem.



> -----Original Message-----
> From: Andrew Sackville-West [mailto:andrew@farwestbilliards.com]
> Sent: May 2, 2007 2:19 PM
> To: debian-user@lists.debian.org
> Subject: Re: Lost Internet Access
> On Wed, May 02, 2007 at 09:03:47AM -0400, Jan Sneep wrote:
> >
> > I said I'd tell you what I discovered ... well I've
> discovered one can't
> > take short cuts in doing an OS Install ... :O(
> ummm... yes you can ;)
> >
> > Tried to leave the \home folder alone and just over write
> the \ folders as I
> this is totally do-able and should not cause you any problems. You
> will have to modify the /etc/fstab after the install to make the /home
> get mounted properly.

Easy when you know how eh ... well using the NetInst CD partitioner you can
also do this paying attention to make sure to specify that you don't want to
format the partion and the mount point as \home.

It did work on one of the FIVE re-installes I tried today ... all of which
have failed yo get my Internet Access back.

> [...]
> > and using PING I found I still had the same problem as
> before, internal
> > addresses are OK, but external ones are a no-go ... :O(
> >
> > So I'll remove the partitions and format the drives and
> start all over again
> > ...
> so, I know this is tough one for a lot of people, but re-installing
> debian is a last resort thing. You can recover from pretty much any
> disastrous state without reinstalling.
> Networking is pretty core to linux and if you're having network
> problems, it is likely *NOT* an issue that needs reinstalling. And in
> fact, often times its not an issue with the linux box, but somewhere
> else.
> So, I recommend you stop reinstalling the system and let the folks
> here help you. Everytime you reinstall the system you are changing
> stuff which makes it harder for these guys to help.

I would have thought that a clean install would have put EVERYTHING right
back to "square one" ... :O)

But you are right I can't seem to get the hard disks 100% clean, it always
seems like the NetInst CD is storing some config file some place as it seems
to remember some of my answers from the previous attempt at installing the
OS. I used the NetInst CD's pPationer to write both hard drives as Fat32 and
then formatted them both using an old Win '98 boot disk, but even if I
include a "?s" to transfer the dos system the Grub booter is still there ...
so I guess I'd have to do a low level format first ... but in any case I
didn't bother.

I changed the two drives around making the 40 gig drive the master instead
of the slave. So now part of the 20 gig dive must have a wee bit of Grub on
it ... oh, well that didn't work either ... :O(

> So. you can ping other boxes on the network, but not outside the net?
> right? can you ping your router/gateway? can you see the router's
> config page from a browser on the debian machine?

No couldn't get to the Routers Config page just wouldn't connect kept
behaving as if I was typing in the wrong password and yet from a IE7 browser
on a Win Xp box, no problemo, bang in every time.

I was at this point in replying to your note Andrew that I thought to give
it one more try now that I had the OS re-installed ... besides I needed to
make one more change to my Routers config settings anyways. And lo and
behold I was in ... but something wasn't right I'm looking at the screens
and wonder why isn't the "wireless" tab showing up? Hang on it is showing me
that it is a BEFSRU1V3 router that I'm connected to, not the WGT54 one I
should be ... but now that I had reset my main router back to factory
default it's password had be reset as well so that's when I clued into what
my problem was ... two DSL router on the network BOTH with a gateway IP
address of ...

Every time I tried to re-install the OS it failed to connect to any of the
mirror sites ... so I figured that some network setting was being retained
in a hidden config file someplace on the hard drive ... re-formatted the
drives ... swapped them around so the 20 gig dive is now the slave instead
of the 40 gig drive ... tried all the mirror sites in the list ... replace
the NIC card in case it was somehow flakey ... also thought that if some how
the router had got stuck with some flag open or something when the power
went out and didn't like the Debian machine changing the NIC would give it a
new MAC address so it wouldn't know it was the same box ... but no .... I
tried four time to re-install the OS with no success at all ... :O(

So finally I figured to shut everybody down and reset the main router back
to factory defaults and after doing basic config changes using one of the
Win Xp machines I plugged in just the Debian box, nothing else, just it and
lo and behold I could connect to a mirror site and everything installed
beautifully ... ya OK took and hour and a half to download the files but YES
I was connecting again .... so while it is merrily chugging along
downloading files I go around and turn up all the other computers and of
course my second router. I use the second router in where my old Win 98
print server is along with the color network printer. I only have one Cat5
cable into that room and it would be a pain to fish another wire in there so
I use a second DSL router with the DHCP turned off as a way of extending the
network access.

It was when the Etch install was complete and it re-booted that it went back
to the second router, who's DHCP was now on, to get an IP address.
Interestingly enough neither router gave out the same address to two devices
and yet they were both configured to start handing out at So
even though a minute ago it was downloading files from the mirror site, now
it can't access the Internet once again ... talk about ready to pull my hair
out !!!

But as usual ONCE you know what the real problem is and have it fix you
think why the heck didn't I think of that sooner ... oh well more experience
under the belt ... :O)

Thanks again for all your help,


No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.5.467 / Virus Database: 269.6.2/784 - Release Date: 2007.05.01
2:57 PM

Reply to: