[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Really annoying! Volume % window that won't go away. After etch upgrade.

Greetings one and all,

I had previously posted about my upgrade to etch on a thinkpad 600E
that went extremely well.  I'm now fixing up all kinds of issues
manually after the same sarge -> etch upgrade on a Dell 8600.

The most annoying and urgent is that on login with kdm, a window
pops up right in the middle of the screen (quite large too) with
"Volume" in extremely large letters and a % status bar which
remains at 0 no matter what I do with the mixer volume control.

Actually, raising the volume with either kmix or alsamixer, does raise
the volume but it immediately goes back down gradually, as if
something is lowering it behind the scenes.  This window has no
border and is unkillable even with xkill.  It also stays if the
foreground, so I can't even hide it.

Killing kmix has no effect, this window comes from somewhere else.

The 8600 has an AC97 and modem/soundcard.  This was an issue in
sarge because of the interaction of the two, but while I was running
a 2.4 kernel, the pctel modem worked fine.  Since I moved to 2.6
the modem has never worked (couldn't even compile it or load it),
although sound was fine.  Since the upgrade, kmix sees both devices:
the modem and the sound card.  Both can be selected and configured.
Yea!  But the master volume is being pulled down by something and
the %$*!@ window won't go away.

I have installed the smartlink modem (sl-modem-daemon) which is
apparently the preferred modem for this machine.  It went in without
a problem.  I look forward to using it as an answering machine since
it apparently does voice.

lspci reports the following:

00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation NV28 [GeForce4 Ti 4200 Go AGP 8x] (rev a1)

I had been running a custom-compiled 2.6.18 kernel under sarge.  After
the bulk of the upgrade, I installed the current 2.6.18 source and
recompiled it with the current (4.1) gcc.  I also compiled the nvidia

Does anyone know where this window comes from?  What process should I
kill?  It remains up even when all other windows are put away to see
the desktop.  I'm using the nvidia driver, which has been working just
fine for years under sarge.

Does anyone know why the volume is being lowered automatically?  I don't
see CPU usage, as if some process has gone crazy.

I'm wondering if might have installed a trojan during the upgrade.  Some
downloads gave warnings about signatures.  Perusing the output of 
ps aux I see this:

root     20392  0.0  0.2   3792  1388 ?        S    17:47   0:00 -:0                                    
What the %&*# is a process called "-:0"?

pstree 20392 gives this:


Which makes sense.  The window pops up unpon graphical login, but
ssh-agent?  Is this normal?  I'm wondering if the :0 refers to display
0, but that process name is strange...

Thanks in advance.  I anxiously away any hint or solution.  I really
want to get rid if this window in the middle of my screen.


Reply to: