[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: more sound problems

> Hi Mark,
> Have your tried doing aplay from a commandline just to eliminate Gnome
> as the source of the problem. I don't use gnome so I can't help you
> there. Can you get the alsamixer to work? Or does it also complain
> that it can't find any device?
> Cheers,
> Jonathan

Alsamixer only works right after I run alsaconf ("Have a lot of
fun!").  However, this is short-lived, and it stops working shortly
thereafter.  Sound never works.  I suspect that alsamixer stops working
right after I try to open any application that uses sound, and any sign
that a soundcard had been set up, or even exists, vanishes.

I get the following error when I try to run alsamixer:

mark@debian:~$ alsamixer

alsamixer: function snd_ctl_open failed for default: No such device

I get the following feedback from aplay:

mark@debian:~$ aplay
ALSA lib confmisc.c:670:(snd_func_card_driver) cannot find card '0'
ALSA lib conf.c:3500:(_snd_config_evaluate) function
snd_func_card_driver returned error: No such device ALSA lib
confmisc.c:391:(snd_func_concat) error evaluating strings ALSA lib
conf.c:3500:(_snd_config_evaluate) function snd_func_concat returned
error: No such device ALSA lib confmisc.c:1070:(snd_func_refer) error
evaluating name ALSA lib conf.c:3500:(_snd_config_evaluate) function
snd_func_refer returned error: No such device ALSA lib
conf.c:3968:(snd_config_expand) Evaluate error: No such device ALSA lib
pcm.c:2143:(snd_pcm_open_noupdate) Unknown PCM default aplay: main:550:
audio open error: No such device

I tried running aplay as root after running alsaconf, and it just gets
stuck.  I then ran alsaconf, changed to regular user, and ran aplay,
which gave the result I've included here above.  

So, no audible cheers here.


Reply to: