[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SoundBlaster AWE64 ISAPNP on etch

On Sat, Feb 03, 2007 at 12:49:23AM -0500, Oliver Twist wrote:
> Cannot get sound up and running on etch.
> Here's my situation:
> AWE64 ISAPNP card (works fine on Windows)
> Just installed etch.  The card is 'detected' on boot, but not 'configured'. 
> I really do not know what sound support is automatically installed on 
> debian.  I figure I need to load the appropriate driver modules, but I am 
> not exactly sure which drivers/modules to load.
> I have tried each of the following:
> # modprobe sb
> # modprobe snd-sbawe
> Either one seems to configure my card:
> /dev/dsp appears
> and
> 'dmesg' results indicate that the card is found and assigned IRQ, DMA and 
> ioport address
> But when I try to play any sort of sound (audio CD, raw PCM file, etc.) I 
> just get static from the speakers.
> I have also tried:
> # modprobe sound
> # modprobe sound-core
> but cannot determine what effect, if any, these have.

In Etch, sound is no longer done with OSS but with Alsa.  So install the
folllowing packages:

Then run alsaconf.  It sets up the card and ensures that the appropriate
modules get loaded. 

Your card should now be set up but it will be muted.  Run your favaorite
alsa mixer and set the levels.

If that doesn't work, come back with the output of lspci for others to
help with.


Reply to: