[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SoundBlaster AWE64 ISAPNP on etch

On Sat, Feb 03, 2007 at 12:49:23AM -0500, Oliver Twist wrote:
> Cannot get sound up and running on etch.
> I know there are a million+ posts on the new regarding sound on linux.  I 
> have tried to do my homework by searching the debian list archives, 
> googling, and I have also read the following HOWTO's:
> linux sound HOWTO
> AWE 32/64 HOWTO
> I've learned a lot, but am having trouble piecing together what I've 
> learned and applying it to this particular distro, and I need a bit of 
> direction.
> Here's my situation:
> AWE64 ISAPNP card (works fine on Windows)
> Just installed etch.  The card is 'detected' on boot, but not 'configured'. 
> I really do not know what sound support is automatically installed on 
> debian.  I figure I need to load the appropriate driver modules, but I am 
> not exactly sure which drivers/modules to load.
> I have tried each of the following:
> # modprobe sb
> # modprobe snd-sbawe
> Either one seems to configure my card:
> /dev/dsp appears
> and
> 'dmesg' results indicate that the card is found and assigned IRQ, DMA and 
> ioport address
> But when I try to play any sort of sound (audio CD, raw PCM file, etc.) I 
> just get static from the speakers.
> I have also tried:
> # modprobe sound
> # modprobe sound-core
> but cannot determine what effect, if any, these have.
> any advice?
the basic advice is to at least include the output of 'lspci' (assuming
its a pci card). And telling us if 'alsaconf' has any problems. Did you
try running 'alsaconf' as root and then using 'alsamixer' to turn up all
the volumes and hit 'm' so that the controls DO NOT SHOW 'm'. 'm' means
mute, but you use 'm' to toggle this.
|  .''`.  == Debian GNU/Linux == |       my web site:           |
| : :' :      The  Universal     |mysite.verizon.net/kevin.mark/|
| `. `'      Operating System    | go to counter.li.org and     |
|   `-    http://www.debian.org/ |    be counted! #238656       |
|   my keysever: subkeys.pgp.net |     my NPO: cfsg.org         |

Attachment: signature.asc
Description: Digital signature

Reply to: