[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: module-assistant/ndiswrapper/kernel-headers

Sven Arvidsson wrote:
On Tue, 2007-01-30 at 12:23 -0800, Freddy Freeloader wrote:
The problem is that there is no kernel-headers package with the same exact package version as the installed kernel version.

The installed kernel is reported as 2.6.18-3-486 by uname -a. The only kernel headers package available with apt-get for Sid or Etch is 2.6.18-6.

Are you sure you have both the linux-kernel-headers and the
linux-headers-2.6.18-4-486 packages installed?

That was the solution. m-a apparently does not search for linux-header or linux-image packages, it uses apt-get to search for kernel-headers and kernel-image, or so it seems anyway. However, once I installed the updated linux-image and linux-headers packages everything worked as it should. The problem probably stems from the fact that of the kernel choices that the Etch installer makes available I chose the one that is not an explicit choice of a kernel version. (I can't recall off the top of my head what the choices are right now though. ) That probably keeps apt from upgrading the kernel until that generic kernel package is updated to the latest kernel image, and that doesn't seem to happen right away as I ran apt-get update, apt-get upgrade, and even apt-get dist-upgrade looking for new kernel packages and nothing showed up. It wasn't until Andrew said that new kernel image and header packages had been made available that I expanded my search to look for linux-kernel and linux-header packages. If I had done that to start with I wouldn't have had a problem. However, it just never occurred to me to try that as I assumed that if anything was available m-a would find it in the "prepare" routine run when setting up m-a.

Reply to: