[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

i386 packages on amd64 arch


I would like to install 32bits packages on my amd64 arch Debian.

I know that some people use a 32bits chroot for this, but I don't think it's 
the best solution.

It's possible to install debs with dpkg --force-architecture and it works for 
most of the packages I've tried.
Of course I have installed 32bits libraries like :
i   ia32-libs           - ia32 shared libraries for use on amd64 and ia64 
i   ia32-libs-gtk     - gtk+ ia32 shared libraries
i A libc6-i386       - GNU C Library: 32bit shared libraries for AMD64
i A lib32asound2  - ALSA library (32 bit)
i A lib32gcc1       - GCC support library (32 bit Version)
i A lib32ncurses5 - Shared libraries for terminal handling (32-bit)
i   lib32stdc++6  - The GNU Standard C++ Library v3 (32 bit Version)
i A lib32z1

I can't use dpkg for real use, what I want is using aptitude.
It would allow me to chose i386 arch deb for packages not present for amd64.
Ideally, It would divert libraries to make them installable with the 64 bit 

For the moment, I tried to put i386 debs in my own repository, maintained with 
reprepro. Aptitude can't find Package file.
reprepro build a tree with main/binary-i386/Packages...
Oh, I tried to symlink binary-i386 to binary-amd64 and modify the Release 
files... No way.

Will I be forced to use a chroot ?

For at least 5 years now, on HP-UX hppa, there is 32bits and 64bits libraries 
and app, working in paralelle...

Attachment: pgpNSiTvFXGbT.pgp
Description: PGP signature

Reply to: