[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

setting up compiz on legacy video

I was about to dismiss this as non-doable, but reading some
posts on a google search convinced me to try out compiz on
etch, so I installed it, making a few recommended changes
to /etc/X11/xorg.conf along the way.

I'm running etch, with all updates as of today.

Hardware is a bit of a clunker: homebuilt Athlon 1.0 ghz, asus MB,
Matrox G450 (16 megs video), plenty enough system ram (768 megs). xorg
7.2 possibly (or is it 7.1.1), with updated matrox driver (1.4.4).

3d has worked well for sometime.

I gather that this is pretty much lowend hardware to work with compiz, 
but it *does* work. It is a bit slow, but the eye candy is there --
slide/pinch window, "shear" on a window, "wrap" the window over to the
next available screen - stuff like that. 

On the other hand, it's not all that usable because the windows
themselves are shrunk to about 1/2 their normal size, and I can't run
them any more maximized than they already are. The kde taskbar is also
shrunk to one half its normal size; in other words, it uses up the
bottom 1/2 of the screen instead of using up all the bottom of the
screen as it does normally. That makes for some applications like
sylpheed incredibly hard to use.

Also, other things slow down appreciably, like mplayer in a window. I
haven't noticed much slowdown with 3d apps, although the only 3d app I
routinely use is stellerium. It's simple enough that I use it as a test
whenever I want to see how well dri is setup, and I don't do anything
much with 3d acceleration beyond that -- but without it, stellarium
feels like I'm running on an XT :(.

There is also some 'bleed-through' in the dri --- for instance if I run
glxgears and stellarium at the same time, I can see the gears rotating
in the sky ;) - also it's noticeable when I run amarok (the visualizer
is apparently using GL), although that is less noticeable and not
really that big of an issue, and this is not a compiz issue, but more a
driver one.

I admittedly haven't done much beyond installing compiz and typing
'compiz --replace' on a konsole (after enabling composite extension in
xorg.conf, of course) so I ask is this expected behavior? Am I "pushing
it" as far as the expected performance of compiz? I saw the video,
thought "wow" but upon trying it for the first time it is as if the
tape broke :(.

Anyone with similar hardware trying this?

David E. Fox                              Thanks for letting me
dfox@tsoft.com                            change magnetic patterns
dfox@m206-157.dsl.tsoft.com               on your hard disk.

Reply to: