[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sarge->etch upgrade hits dependency hell

On Thu, Dec 07, 2006 at 04:50:34PM -0500, Douglas Tutty wrote:
> On Thu, Dec 07, 2006 at 02:49:57PM -0500, hendrik@topoi.pooq.com wrote:
> > After failing to reconstitute my etch system (details abundantly 
> > available on this mailing list a few months ago), I wiped its partition 
> > and tried to install etch form scratch using installer release candidate 
> > one, only to find that lilo crashed when it was trying to make the 
> > system bootable (installation report has been submitted).
> > 
> > So my next attempt was to copy the still-running sarge system I have on 
> > another partition into my etch partition, and to try to upgrade the copy 
> > to etch by changing /etc/apt/sources to read 'etch' where the old one 
> > reads 'sarge', starting aptitude, and upgrading.
> Hi Hendrik,
> It would have been easier (and still may be) to fix the boot loader
> thing on etch than what you've tried.
> When I installed Etch (pre RC1), grub didn't get installed.  I rebooted
> the installer in rescue mode and installed grub from there and it
> worked.  You could try that with lilo or switch to grub.

What I did in that situation was to boot to the sarge system I also had 
on that system, and use *its* lilo to add the new etch to the boot menu.  
Worked like a charm, except that etch, now on the boot menu, still 
wouldn't actually boot.

-- hendrik

Reply to: