[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Mounting FreeBSD Partition on Linux

Amit Joshi wrote:
On Monday 27 November 2006 19:54, Matus UHLAR - fantomas wrote:

looking at /boot/config-2.6.8-3-686, it's allowed in debian kernels:


Then, you need UFS filesystem support. Luckily, UFS write support is
dangerous for some versions of UFS, but it's safe for FreeBSD's UFS
(however I'm not sure if that woeks with softupdates...)

Last time I tried work with FreeBSD partitions on linux, it worked. I would
try it again, after backing up...

however, looking again at /boot/config-2.6.8-3-686, writing is not allowed
in debian kernels:

# CONFIG_UFS_FS_WRITE is not set

Yes. I checked out the config file of my kernel, and I saw the same line there too. But now, there's a problem. I can't boot to FreeBSD. It is giving me some errors. I don't know if _trying_to_mount_ the FreeBSD partition on Linux has somehow corrupted the data on it! ( But I don't seriously think mount can do any damage). Last time I had tried to mount it, I got the errors such as "Wrong FS Type" etc.

Anyways, keeping my fingers crossed. Can anybody tell me how do I go
about mounting the partition?
does the kernel report anything about the connected drive and
partitions on it?
I am not sure what are you trying to ask here. Does the kernel report
anything about the connected drive?? Umm.no idea! How do I check that?

Well..fdisk -l /dev/hdb says that this hard disk has a partition tagged
as FreeBSD.  Does it help?
the fact that fdisk can create partition marked as FreeBSD, and fact that
fdisk can create FreeBSD disklabel on such partition, does not mean that
the kernel can do that. However using: "dmesg | grep hdb" should tell you
if your kernel recognizes it...

Ok. I guess fdisk does recognize it. What do you think?

debian:~# dmesg | grep hdb
    ide0: BM-DMA at 0xe000-0xe007, BIOS settings: hda:DMA, hdb:DMA
hdb: SAMSUNG SV0412H, ATA DISK drive
hdb: max request size: 128KiB
hdb: 78242976 sectors (40060 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(33)
hdb: cache flushes supported
 hdb: hdb1
 hdb1: <bsd: hdb5 hdb6 hdb7 hdb8 hdb9 >

Check out the last line. Is it like I need to mount these partitions instead of /dev/hdb1? Do they represent Well...I am pretty new to this BSD style of Partitioning. I read in the Handbook that FreeBSD can only be installed on a primary partition. Then I created one Primary partition, and let it setup the partition automatically. Then I don't know what is it called - it created like /, /var/, /usr etc inside this primary partition. Can anybody explain this? I guess this makes is quite relevant to my inability to mount the partition. Here are the precise details of the setup...(it created these folders/slices/partitions ..whatever!! ..on selecting the _auto_configure_ option.
ad1s1a      512MB       /     UFS2
ad1s1b      422MB       /     SWAP
ad1s1d      1235MB     /      UFS2+S
ad1s1e       512MB      /      UFS2+S
ad1s1f       17313MB    /      UFS2+S

This works in Etch, can't guarantee it will work anywhere else

mount -t ufs -r -o ufstype=ufs2 /dev/hda9 /mnt

this mounts the /usr partition in freebsd 6.2RC, read only, I do not think writing is supported, but I only want to read off the disk anyway.


Reply to: