[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: argh! linux and floppies

[This message has also been posted to linux.debian.user.]
In article <7b5af-3b5-47@gated-at.bofh.it>, Kent West wrote:
> I have just 30 minutes ago tried to use three 3.5" floppies on two
> different machines, and can't get anywhere with them. I decided to put
> it on the back burner and read my email when I came across your post.

Could be the media.
I have twenty year old floppy disks with no defects.
Most floppies I've bought in the last ten years went bad
within eighteen months.  The old ones had a fungicide
to protect the glue from mold.  They don't seem to do
that any more.  I stopped buying new floppies when I got a
box where a third had to be scraped before they
would work.  Surplus places have old ones, unsold antique
software still in the EULA wrap.  Those work better.

Try scraping the mold off with a couple of
  fdformat -n /dev/fd0u1440
passes before you try to write real data it.
Then check it for errors with
  dd if=/dev/fd0 conv=noerror | sum
or something.
But if you salvage a bad disk that way, don't expect the
data on it to last more than a week or two.
Try cleaning the head in the drive with a qtip and
rubbing alcohol.

> I've tried cfdisk and fdisk to look at the partition(s) (do these work
> on floppies?), and mformat, and mkfs.vfat, and fdformat, and all I ever

There's a master boot record on the first sector.
But the bytes at the end where the partition table
goes aren't used.

> get is something like "could not get geometry of device" or "Problem
> reading cylinder 0" or "Unable to read /dev/fd0", etc.

Fdisk and mformat are failing because they read before
writing anything.  An old floppy (more than a month
since you wrote it last) has faded.  You need to write a
new set of sector marks with fdformat before it will
read reliably.  Cfdisk will still fail because there's
no "geometry" to get.


Reply to: