[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: fstab problem



On 6/30/06, John Miller <jmiller@thecsl.org> wrote:
Ron Johnson wrote:
> John Miller wrote:
> >> Deephay wrote:
> >>> Greetings all,
> >>>
> >>> I have a problem with my /etc/fstab and the system cannot boot.
> >>> I copied a fstab file from another machine, but I fogot that the file
> >>> system of the root volume on that machine is ext3 but the one I have
> >>> is XFS, so the system cannot boot anymore.
> >>> Luckily I have a LiveCD and I boot the LiveCD system and change the
> >>> fstab:
> >>>
> >>> # <file system> <mount point>   <type>  <options>       <dump>  <pass>
> >>> proc            /proc           proc    defaults        0       0
> >>> /dev/hda3       /               xfs     defaults,errors=remount-ro
> >>> 0       1
> >>> /dev/hda8       /boot           ext3    defaults        0       0
> >>> /dev/hda9       none            swap    sw              0       0
> >>> /dev/hdc        /media/cdrom0   iso9660 ro,user,noauto  0       0
> >> Are you sure that these are the correct partitions for the disk?  It
> >> seems a bit odd that you don't have /dev/hda1 or /dev/hda2 being used
> >> for something.  Did the live cd detect the above?
>
> hda1 & hda2 might be used by Windows.

yes they are used by windows (NTFS) and I omitted them.

>
Sure might be.  Deephay said that he copied his /etc/fstab file from
another machine, though.  Given that his initial question is about
/etc/fstab, it makes sense to double-check it.
> >>> but the system can only boot to runlevel 2, and the message said that
> >>> the '/' is not mounted yet (wrong option).
> >>> So, how can I write a correct fstab?
> >> The system booted to runlevel 2 without a root filesystem?  How?
> >> Anyway, runlevel 2 is the Debian default, so _only_ booting to runlevel
> >> 2 isn't a bad thing unless you've specified otherwise....
>
> It's my impression that he booted using the LiveCD.
>
Mine too--my take was that he copied over /etc/fstab while the system
was still running; tried to boot, but couldn't; booted using the
LiveCD's root partition; mounted the hard disk; fixed /etc/fstab; then
tried to boot without the LiveCD.

It would certainly have been possible to boot from the LiveCD, but using
the hard disk's root partition.  Was that your take on the matter?

--John


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org



I solved the problem by change:
/dev/hda3       /               xfs     defaults,errors=remount-ro  0 1
to:
/dev/hda3       /               xfs     defaults



Reply to: