[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: /usr/X11R6/lib softlinks lost - Thanks

On Wed, Jun 07, 2006 at 10:29:19AM +0100, Liam O'Toole wrote:
> On Tue, 06 Jun 2006 17:26:51 -0400
> "Thomas H. George" <tom@tomgeorge.info> wrote:
> > In the xorg update there was an advice to save the files in /usr/X11R6
> > so the bin directory could be replaced with a softlink to /usr/bin.
> > Once this had been done the programs that were in usr/X11R6/bin could
> > be moved to /usr/bin and the other files & directories could be moved
> > back to /usr/X11R6.
> > 
> > To comply I did mv /usr/X11R6 /usr/X11R6Saved
> > 
> > After the update I forgot to move things back and gdm would not start
> > X Windows.
> > 
> > I remembered what I had not moved and tried mv /usr/X11R6Saved/lib
> > /usr/X11R6.  This failed as there was a new X11 in /usr/X11R6 and mv
> > aborted rather than overwrite this.  Accordingly I tried mv
> > /usr/X11R6Saved/lib *. /usr/X11R6/lib.  This moved all the files but
> > the softlinks were lost.
> > 
> > Now gdm started X Windows for 10 seconds, then exited with a message
> > 
> > 	dbus-launch: error while loading shared libraries:
> > libICE.so.6: cannot open shared object file.
> > 
> > I restored the softlinks for libICE.so to libICE.so.6 to libICE.so.6.4
> > but this has not solved the problem.  There are a great many such
> > softlinks in the lib.
> > 
> > Is this a clue to what I must do to solve the problem?  If so, does
> > anyone know the answer?
> > 
> > Tom George
> > 
> > 
> Some of the X-related packages in etch are still at version 6.9:
> otoolel@po:~$ apt-show-versions | grep 6.9.0
> libxaw8/etch uptodate 6.9.0.dfsg.1-6
> libice6/etch uptodate 6.9.0.dfsg.1-6
> xlibs/etch uptodate 6.9.0.dfsg.1-6
> libxaw8-dev/etch uptodate 6.9.0.dfsg.1-6
> libice-dev/etch uptodate 6.9.0.dfsg.1-6
> Hopefully, reinstalling them will restore the necessary files
> in /usr/X11R6/lib. So, try 'apt-get install --reinstall libxaw8 libice6
> xlibs'.
> -- 
> Liam
Thanks, this did solve the problem.

There was one catch.  I realized because the softlinks were missing I
must have copied the files from X11R6Saved/lib to X11R6/lib with cp *.* rather
than moving them with mv *.*.  I went back and redid this and then
reistalled the three files libxaw8, libice6, and xlibs.  The result was
an unusable system - X Windows started and immediately restarted when the
first letter of the user name - or any key - was pressed.  Worse, it was
impossible to break this loop and switch to a console.

I escaped by rebooting to a bbc-2.1 cd, making the partitions writable
and moving all the files back to X11R6Saved.lib.  When I then rebooted from
the harddrive gdm tried to start X Window and failed allowing me access
to a console.  Finally, I reinstalled the three files and restarted gdm
and all was fine.

These three files are the only files in /X11R6/lib now.  There is more
than a page of three columns of files in /X11R6Saved/lib but apt-get -f
install finds no problems.  At some point the lack of these files in
X11R6/lib may cause new problems?

This task was more painful as, after the dist-upgrade, my system locks
up during shutdown when it tries to stop the rsync daemon.  This occurs
before the files are unmounted so at every reboot they must all be
repaired.  I posted this problem several days ago but have had no responses.

Tom George
> -- 
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org 
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: