[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

/usr/X11R6/lib softlinks lost

In the xorg update there was an advice to save the files in /usr/X11R6
so the bin directory could be replaced with a softlink to /usr/bin.
Once this had been done the programs that were in usr/X11R6/bin could be
moved to /usr/bin and the other files & directories could be moved back
to /usr/X11R6.

To comply I did mv /usr/X11R6 /usr/X11R6Saved

After the update I forgot to move things back and gdm would not start X

I remembered what I had not moved and tried mv /usr/X11R6Saved/lib
/usr/X11R6.  This failed as there was a new X11 in /usr/X11R6 and mv
aborted rather than overwrite this.  Accordingly I tried mv
/usr/X11R6Saved/lib *. /usr/X11R6/lib.  This moved all the files but the
softlinks were lost.

Now gdm started X Windows for 10 seconds, then exited with a message

	dbus-launch: error while loading shared libraries: libICE.so.6:
	cannot open shared object file.

I restored the softlinks for libICE.so to libICE.so.6 to libICE.so.6.4
but this has not solved the problem.  There are a great many such
softlinks in the lib.

Is this a clue to what I must do to solve the problem?  If so, does
anyone know the answer?

Tom George

Reply to: