[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: /usr/X11R6/lib softlinks lost

On Tue, 06 Jun 2006 17:26:51 -0400
"Thomas H. George" <tom@tomgeorge.info> wrote:

> In the xorg update there was an advice to save the files in /usr/X11R6
> so the bin directory could be replaced with a softlink to /usr/bin.
> Once this had been done the programs that were in usr/X11R6/bin could
> be moved to /usr/bin and the other files & directories could be moved
> back to /usr/X11R6.
> To comply I did mv /usr/X11R6 /usr/X11R6Saved
> After the update I forgot to move things back and gdm would not start
> X Windows.
> I remembered what I had not moved and tried mv /usr/X11R6Saved/lib
> /usr/X11R6.  This failed as there was a new X11 in /usr/X11R6 and mv
> aborted rather than overwrite this.  Accordingly I tried mv
> /usr/X11R6Saved/lib *. /usr/X11R6/lib.  This moved all the files but
> the softlinks were lost.
> Now gdm started X Windows for 10 seconds, then exited with a message
> 	dbus-launch: error while loading shared libraries:
> libICE.so.6: cannot open shared object file.
> I restored the softlinks for libICE.so to libICE.so.6 to libICE.so.6.4
> but this has not solved the problem.  There are a great many such
> softlinks in the lib.
> Is this a clue to what I must do to solve the problem?  If so, does
> anyone know the answer?
> Tom George

Some of the X-related packages in etch are still at version 6.9:

otoolel@po:~$ apt-show-versions | grep 6.9.0
libxaw8/etch uptodate 6.9.0.dfsg.1-6
libice6/etch uptodate 6.9.0.dfsg.1-6
xlibs/etch uptodate 6.9.0.dfsg.1-6
libxaw8-dev/etch uptodate 6.9.0.dfsg.1-6
libice-dev/etch uptodate 6.9.0.dfsg.1-6

Hopefully, reinstalling them will restore the necessary files
in /usr/X11R6/lib. So, try 'apt-get install --reinstall libxaw8 libice6



Reply to: