[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Long delay when printing from XP (over samba, cups, raw)

Hi all together,

I set up a SAMBA-Server as Primary Domain Controller. Everything works
so far, I can logon to domain, get printers and shares, etc...

But when I start a print job in windows xp nothing happens for about 3-5
minutes an then it is printed (without problems).

On Linux side I installed a RAW-Driver an use the Windows drivers. 

The smb.conf printers section looks like this:

	comment = All Printers
	path = /var/spool/samba
	printer admin = stephan
	create mask = 0700
	printable = Yes
	browseable = No
	public = Yes
	use client driver = Yes

My global section like this (partly created by SWAT):

	workgroup = BUERO
	netbios name = Server

	# we make him the Primary Domain Controller
	domain logons = yes
	security = user
	password server = UbuntuServer
	local master = yes
	os level = 65
	preferred master = yes
	domain master = yes
	logon script = logonscr.bat
	logon drive = X:
	logon path = \\Server\profiles\%U
	admin users = root, administrator, Administrator	

	server string = %h server 
	obey pam restrictions = Yes
	passdb backend = tdbsam, guest
	passwd program = /usr/bin/passwd %u
	passwd chat = *Enter\snew\sUNIX\spassword:* %n\n
*Retype\snew\sUNIX\spassword:* %n\n .
	syslog = 0
	log file = /var/log/samba/log.%m
	max log size = 1000
	printcap name = cups
	show add printer wizard = No
	dns proxy = No
	ldap ssl = no
	panic action = /usr/share/samba/panic-action %d
	printing = cups
	print command = 
	lpq command = %p
	lprm command = 

It would be really nice if someone could help me with that issue...
Best wishes, Stephan

Reply to: