[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: APT-GET problem: does not have a corresponding .info file

On Sat, May 20, 2006 at 04:29:49PM +0300, Cem Kamil Kulekci wrote:
> Hi,
> I just installed mod_evasive apache module and it is working fine. But
> after that I cannot install or remove anything with apt-get. ex. when
> i try to install libapache-mod-perl, got error below;
> Reading Package Lists... Done
> Building Dependency Tree... Done
> libapache-mod-perl is already the newest version.
> 0 upgraded, 0 newly installed, 0 to remove and 19 not upgraded.

> 1 not fully installed or removed.
this is your problem. until you clear out that 1 package you will not
be able to install anything.

> Need to get 0B of archives.
> After unpacking 0B of additional disk space will be used.
> Setting up libapache-mod-perl ( ...
> Error: mod_evasive.so does not have a corresponding .info file.
> The above errors might cause apache to not work properly or start
> Please refer to the documentation on how to fix it or report it to
> Debian Apache Mailing List <debian-apache@lists.debian.org> if in doubt
> on how to proceed
> dpkg: error processing libapache-mod-perl (--configure):
> subprocess post-installation script returned error exit status 20
> Errors were encountered while processing:
> libapache-mod-perl
> E: Sub-process /usr/bin/dpkg returned an error code (1)

I'm curious why it refers you to debian-apache unless there is some
apache specific stuff going on here in the install. I would guess this
is definitely a packaging bug. Can you unpack the .deb and locate the
.info file anywhere? maybe the install scripts are looking in the
wrong place. 


Attachment: signature.asc
Description: Digital signature

Reply to: