[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dhcp, router and debian


I have installed a D-Link DI-524 wireless/ethernet router between my
cable modem and my PC. It worked fine on the first 5 (or so) sessions,
but now when I start up debian, the startup item `ATM' takes ages to
finish (it says `exim4' in the end) and I have no internet connection
Are you sure you aren't seeing MTA?
 If you are, that is probably exim starting, which on a few of my
 systems caused boot delays. This caused no problem however, in my case
 at least.
exim is the systems mailer, delevering mail between users, on certain
 events, etc.
Have you tried ifconfig after you are logged in? You will have to
 either use sudo, or su from a non-privelaged account.

I'm sorry, yes it was MTA.

The thing is, after my computer halts (and no wireless connections are
in use), I usually switch off the whole box by switching off the power
socket. So when I fire up the system, the modem + router are usually
just starting as well.
In some way, this works for windows and not for linux. After I boot in
windows and restart in linux (without switching off the power socket),
the connection is just fine.

When the connection works I get something like this:
$ sudo /sbin/ifconfig eth0
eth0   Link encap:Ethernet  HWaddr ##:##:##:##:##:##
       inet addr:  Bcast:  Mask:
       RX packets:804 errors:0 dropped:0 overruns:0 frame:0
       TX packets:696 errors:0 dropped:0 overruns:0 carrier:0
       collisions:0 txqueuelen:1000
       RX bytes:171908 (167.8 KiB)  TX bytes:54151 (52.8 KiB)
       Interrupt:11 Base address:0x2000
I can ifdown and ifup my network card as often as I like.

When the connection doesn't work it does exactly the same thing. This is only for the connection Linux PC <-> router...

The only thing I can think of is that it is the router that cannot get a connection to the internet/my ISP. Although that does not make sense, does it? I mean, the router is a standalone device, that does not need a windows or linux PC to run (maybe for setting it up via its html page, but that's it).

The setup html page for the router (the dhcp part) has got fields to fill in (like DNSes, masks, etc) but usually it runs without those. Would it be necessary to fill in these values to guarantee it working with linux? Can't remember ever being told my ISP's DNS.

Thanks for your help,
Alle Meije

Reply to: