[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Etch on USB-HD wont boot - race condition?

On Mon, May 01, 2006 at 09:10:20AM -0400, George Hein wrote:
> Kai Olsen wrote:
> >Hi list.
> >
> >I'm trying to get etch to boot from an USB-attached harddisk on my 
> >notebook but the kernel cannot find the root filesystem. It seems to 
> >me, that udev hasn't finished its job by the time the kernel wants to 
> >read from the disk so /dev/sda isn't defined yet.
> >
> >Any ideas as to how I can control the timing of the process? It might 
> >entail editing the initrd image - how's that done?
> >
> >I had an initial problem that I think I got solved: On boot, the bios 
> >assigns the bootdisk as (hd0) in grubsk whereas during installation 
> >grub sees the USB-disk as (hd1). I edited /boot/grub/menu.list, 
> >repacing (hd1) with (hd0). It's just that the kernel, when it wakes up, 
> >needs to see the disk as /dev/sda and udev (or the disk) isn't fast 
> >enough... The first disk (100GB) contains WinXP and I want it to be 
> >untouched.
> >
> >Output from dmesg:
> >----------------
> >Probing IDE interface ide0...
> >usb 3-1: new high-speed USB device using echi-hcd and address 2
> >SCSI subsystem initialized
> >Initializing USB Mass Storage driver...
> >hda: SAMSUNG HM100JC, ATA DISK drive
> >scsi0 : SCSI emulation for USB Mass Storage devices
> >usbcore: registred new driver usb-storage
> >USB Mass Storage support registered
> >usb-storage: device found at 2
> >usb-storage: waiting for device to settle before scanning
> >usb 1-3: new low-speed device using ochi_hcd and address 3
> >ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
> >Probing IDE interface ide1...
> >ide1 at 0x170-0x177,0x3f7 on irq 15
> >hda: max request size: 1024KiB
> >hda: 195371568 sectors (100030 MB) w/8192KiB cache, CHS=16383/255/63, 
> >UDMA(100)
> >hda: cache flushes supported
> > hda: hda1 hda2 < hda5 >
> >hdc: ATAPI 24x DVD-ROM DVD-R-RAM CD-R/RW drive, 2048kB cache, UDMA(33)
> >Uniform CD-ROM driver Revision: 3.20
> >Done.
> >Begin: Mounting root file system... ...
> >Begin: Running /scripts/local-top ...
> >/scripts/local-top/lvm: 36: vgchange: not found
> >Done.
> >ALERT! does not exist. Dropping to a shell!
> >
> >
> >BusyBox v1.01 (Debian 1:1.01-4) Built-in shell (ash)
> >Enter 'help' for a list of built-in commands.
> >
> >/bin/sh: can't access tty; job control turned off
> >/ #   Vendor: HTS54104  Model:0G9AT00		Rev: MB20
> >  Type:   Direct-Access                     ANSI SCSI revision: 00
> >SCSI device sda: 78140159 512-byte hdwr sectors (40008 MB)
> >sda: assuming drive cache: write through
> >SCSI device sda: 78140159 512-byte hdwr sectors (40008 MB)
> >sda: assuming drive cache: write through
> > sda: sda1 sda2 < sda5 sda6 sda7 sda8 sda9 >
> >sd 0:0:0:0: Attached scsi disk sda
> >--------------------
> >
> >TIA Kai Olsen
> >
> >
> I tried fooling with this a few months ago and failed. I tried it with 
> SUSE, Debian-test&sid and RIP.  Everything works to a point where Linux 
> kernel cannot find itself or root partition as it boots half way thru.
>  I reverted to simply putting RIP (RecoveryIsPossible) on my USB-HD for 
> now in a VFAT partition-sda1, using GRUB on sda4 to boot that or 
> partitions on hda or hdc on my thinkpad-t42.
> As to fear of adding linux to hda and hdb no problem, done it many times 
> without affecting WinJunk.
> If you arrive at a solution I hope you post it here.  I do not expect 
> this to get on the forum, for many of my replies get lost.

this is a guess. Once the boot loader finds the kernel, it needs to
load the modules for the root file system. If the root file system is on
a usb hd, all those modules for usb & root fs type and what ever must be
in the compiled kernel and not as modules. Is this the case? Also, it
seems that the boot loader sees the external hd as /dev/hda but then you
load moduels that change this to /dev/sda (or vise versa). These should
be the same; if you can do this, that would help also.
|  .''`.  == Debian GNU/Linux == |       my web site:       |
| : :' :      The  Universal     | debian.home.pipeline.com |
| `. `'      Operating System    | go to counter.li.org and |
|   `-    http://www.debian.org/ |    be counted! #238656   |
|     my keysever: pgp.mit.edu   |     my NPO: cfsg.org     |

Attachment: signature.asc
Description: Digital signature

Reply to: