[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Etch on USB-HD wont boot - race condition?

>----Oprindelig meddelelse----
>Fra: zweistein@optonline.net
>Dato: 01/05/2006 15:10
>Til: "Kai Olsen"<kai-linux@sol.dk>
>Emne: Re: Etch on USB-HD wont boot - race condition?
>Kai Olsen wrote:
>> Hi list.
>> I'm trying to get etch to boot from an USB-attached harddisk on my 
>> notebook but the kernel cannot find the root filesystem. It seems 
>> me, that udev hasn't finished its job by the time the kernel wants 
>> read from the disk so /dev/sda isn't defined yet.
>I tried fooling with this a few months ago and failed. I tried it 
>SUSE, Debian-test&sid and RIP.  Everything works to a point where 
>kernel cannot find itself or root partition as it boots half way 

Right on target!

>  I reverted to simply putting RIP (RecoveryIsPossible) on my USB-HD 
>now in a VFAT partition-sda1, using GRUB on sda4 to boot that or 
>partitions on hda or hdc on my thinkpad-t42.

I don't think I know RIP. Any info?

>As to fear of adding linux to hda and hdb no problem, done it many 
>without affecting WinJunk.
I need all the space I can get on the windoze disk as I use it as a 
DVD-recorder for the TV. But you're right, a basic install doesn't use 
much space, and I might end op with using a couple of gigs on hda for 
the root fs.

>If you arrive at a solution I hope you post it here.  I do not 
>this to get on the forum, for many of my replies get lost.

Well, George... It's probably because you answered directly to my 
email-adr and not to the list :-) I too have to edit the "To:" line 
when answering mails on the list.

Cheers. Kai.

Reply to: