[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Some errors since recent upgrades

On Sun, Apr 23, 2006 at 22:24:34 +0300, David Baron wrote:
> On Sunday 23 April 2006 22:03, Florian Kulzer wrote:


> > dpkg -l xprint{,-common} lib{c6,freetype6,x11-6,xau6,xdmcp6,xfont1} zlib1g
> >
> xprint 1.0.1-1
> xprint-common 1.0.1-1
> libc6 2.3.6-7 (may have been upgraded today)
> libfreetype6 2.1.10-3
> libx11-6 1.0.0-6
> libxau6 1.0.0-3
> libxdmcp6 1.0.0-4
> libxfont1 1.0.0-4
> zlib1g 1.2.3-11
> > sudo /etc/init.d/xprint restart
> Restarting Xprint server(s): Xprt.
> Stopping Xprint servers: Xprt.
> Starting Xprint servers: Xprt.
> /etc/init.d/xprint: ## WARNING: Can't find 
> "/usr/X11R6/lib/X11/fonts/encodings/encodings.dir", TrueType font support may 
> not work.
> david@d_baron:~$
> Fatal server error:
> Xp Extension: could not find config dir /usr/X11/xserver/C/print
> Xprint server pid=18970 done, exitcode=0.

OK, I have the same versions of xprint, xprint-common and the rest. Like
you I do not have have the file/directory


but my xprint restarts without complaining. One possible explanation for
what your are seeing might be that you have some old config file
somewhere which did not get upgraded properly and still points to the
depreciated locations.

You could try to purge xprint and reinstall it; this will make sure that
you get all the new config files.

apt-get --purge remove xprint xprint-common
apt-get install xprint xprint-common

I would hope that this will fix your system.


Reply to: