[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Configuring network printer using gnome/foomatic on Debian



On Tue, 14 Mar, Pabla,Balbir Ontario wrote:
> I have a HP laserjet 8000 DN printer attached to network directly with
> ip address say 142.xx.xxx.yyy.
> I want to send print jobs from Debian 3.1 system running 2.4 smp kernel.
> I tried from gnome window : system tools; printer; add printer
> information manually, it asks for printer information, I am not sure ,
> what should I type in my case?
> 
> I tried : 142.xx.xxx.yyy , it did not complain, but at the same time it
> s not printing even test page.
> Any help on configuring network printer, troubleshooting tips from
> system admin and user point of view etc...?
> 
Balbir,

I had the same sort of trouble installing printers recently in the same environment as yours. In the end I completely removed the CUPS package (i.e. purge which removes config scripts as well). I then re-installed CUPS and any printer specific packages (there are two that relate to HP inkjets that seemed to be recommended, for instance) and did /etc/init.d/cupsys restart as root.

The next stage was to actually install the printers. In my notes I've got the following: "WARNING! Do NOT use Desktop -> Administration -> Printers". As far as I can work out it's horribly broken even though it reports itself as doing all the right things.

Instead I fire up a browser and go to http://localhost:631/ Add to Hotlist  where I choose 'Add Printer', and choose 'http' as the Internet Printing Protocol and for the 'Device URI:' I put in 'socket://142.xx.xxx.yy:9100'.

I hope this is of some use.

Nigel

-- 
Nigel Pauli
Network Manager
St. John's School, Northwood







Reply to: