[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[SOLVED] Re: Basic help with HP5440 inkjet?

I eventually found a conflict between the printer and a logitech quickcam I also had plugged into the machine. Once I removed the quickcam, the printer worked perfectly.

So, this still begs the question of why they conflict, but it's a problem I can put on the back burner for now.

Jerry Quinn

Jerry Quinn wrote:
Hi, all.

I bought an HP 5440 based on the recommendations of linuxprinting.org. So far I've had no success getting the printer to work, though. At the moment, I suspect something at the USB level. This is on etch testing as of today.

When I plug the printer in, I see the following in kernel.log:

Feb 13 23:31:16 smaug kernel: usb 3-1: USB disconnect, address 3
Feb 13 23:31:19 smaug kernel: usb 3-1: new full speed USB device using uhci_hcd and address 4

When I try to create a cups printer queue for the HP, the only URI offered of type hp: is hp:/no_device_found, which isn't so useful and doesn't work, of course.

There's a tool called hp-probe which seems to be designed for locating printers. When I run it with debug logging, I get the following:

smaug:~#  hp-probe --logging=debug -busb

 HP Linux Imaging and Printing System (ver. 0.9.7)
 Device Detection (Probe) Utility ver. 1.3

 Copyright (c) 2003-5 Hewlett-Packard Development Company, LP
 This software comes with ABSOLUTELY NO WARRANTY.
 This is free software, and you are welcome to distribute it
 under certain conditions. See COPYING file for more details.

 [DEBUG]: Sending data on channel (3)
[DEBUG]: 'msg=probedevicesfiltered\nfilter=none\nbus=usb\nformat=cups\ntimeout=5\nttl=4\n'
 [DEBUG]: Reading data on channel (3)
[DEBUG]: 'msg=probedevicesfilteredresult\nresult-code=0\nnum-devices=0\nencoding=none\nlength=0\ndata:\n'
 [WARNING]: No devices found. If this isn't the result you are expecting,
 [WARNING]: check to make sure your devices are properly connected.

Reply to: