[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Fwd: acpi and backlight issue

I sent this to debian-laptop but I'm hoping to get some added input
from the gurus here.  This problem is driving me up a wall.

Thanks much.


---------- Forwarded message ----------
From: David Berg <drberg1000@gmail.com>
Date: Feb 22, 2006 5:19 PM
Subject: acpi and backlight issue
To: debian-laptop@lists.debian.org

I recently switched my uniwill 245II0 laptop from Ubuntu to Debian
Sarge with the 2.6.8 kernel.  Upon doing so my backlight stopped
comimg on after a lid event.  See my previous thread in debian-laptop
for everything I tried (from vbetool and vbe_post to different kernels
and acpi scripts).

I finally made a little progress by installing the 2.4.27 kernel.
Looking at the .config file I found that it disabled ACPI by default.
Without ACPI the lid button caused the system to go into some type of
suspend.  I'd prefer the flexibility of acpi but am willing to forgoe
it for the time being.  Problem is removing acpi from the kernel
(either 2.4.27 which has it off by default or 2.6.8 by passing
acpi=off) causes me to loose my synaptics mouse and atheros card

The mouse seems to work fine with gpm but I haven't been able to get
it to function in X even with trying various input devices and
protocols.  I've also tried turning off gpm before starting X.  When
using the synaptics driver X complains about the evdev  modules being
missing (atleast with the 2.4 kernel).

The madwifi drivers load and iwconfig sees the interface but it
doesn't get any signal.  There is a switch that turns off the radio
and a led that normally reflects the state of the switch.  Without
ACPI that led remains off regardless of the switch state and it would
appear that the radio does remain off.

I know this e-mail is not quite a good example of ESR's smart
questions, but this problem is driving me up the wall.  I'm beginning
to have a hard time approaching it rationally.  I'd just install
ubuntu again if I thought it would help.  However, the live cd
produces the same behavior as debian does with acpi enabled.

ANY suggestions greatly appreciated.  I'm starting to wonder if there
isn't a hardware problem instead of a software configuration issue.

Thanks in advance.


Reply to: