[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sharing Linux printer with Mac

Adam James wrote:
On Sun, 2006-01-22 at 02:49 -0500, Chinook wrote:
Chinook wrote:
The issue is something that I wondered about (and commented on) early on. On my Mac I see the printer EpsonSPR300@debian1 but my Mac can't actually print to it because my Mac (via my router) can't resolve the hostname "debian1."

When I first put up Debian on the P4, I noticed that where my Mac sets a hostname with its local address on my Belkin router, the Linux box leaves the hostname blank on my Belkin router. My router does have the Linux box represented as an address (, but no hostname.

When the printer was attached to my Mac I could print to it from my Linux box it because the Mac hostname (pmacg5) could be resolved by the router, but now that the printer is attached to my Linux box (and working there) I can't print to it from my Mac because it can't resolve the Linux box hostname (debian1) :-(((( I had a strong feeling this hostname issue would come back to bite me %-\

So, whats to do? Preferably I'd really appreciate some help in getting Debian to post its hostname on the router like my Mac does. If that can't be done at the moment, then I would appreciate some help in getting my Mac to resolve the Linux box hostname to an address (

I am presuming that the Debian host is getting it's IP address via DHCP
from your router. If so, you might want to take a look
at /etc/dhclient.conf. Try adding the line:

send host-name "debian1";

and see if it makes any difference.

The myriad of dhcp options are explained in man dhcp-options and the
syntax of dhclient.conf is explained in man dhclient.conf (surprising I

Of course if you aren't using DHCP then you can safely ignore this

Good luck,
Thanks for the suggestion Adam,

Now I know the hostname on the router is not the issue :-(

I added the line to dhclient.conf and I now see the Linux box hostname in the router configuration interface. Trying to print from my Mac afterwards yields the same error though - it can't resolve the hostname "debian1."

So I guess I'm back to flailing around :-) I'm looking further into how my Mac is trying to resolve the Linux box hostname. Is there a possibility that this could be a CUPS client side issue (as opposed to an OS X issue)?

Thanks again,
Lee C
"Old age is too high a price to pay for maturity. " -- unk


So far I've fount the info you gleaned (re: netinfo) is outdated. I'm looking into the nitty-gritty of how such works now in Tiger.

Thanks again,
Lee C

Reply to: