[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't Get Exim4 Setup Right

On Mon, Jan 09, 2006 at 09:53:45AM -0500, Thomas H. George wrote:
   > Andrei wrote:
   >    Try #tail /var/log/exim4/mainlog immediately after trying to send a 
   > message from Mutt.
   > I did and found "host outgoing.verizon.net ... Authentication 
   > Required."  I edited /etc/exim4/passwd.client and added a line 
   > outgoing.verizion.net:name:password using, of course, the account name 
   > and password.  This did not work.  I also tried changing outgoing to 
   > mail but this too did not work.
I too faced the same problem with exim4 setup. The passwd client seems
to be debian specific. But it did not work. Just went ahead and edited 
/etc/exim4/conf.d/auth/30_exim4-config_examples to include the login id
and password. Just including below the relevanty section:

  driver = plaintext
  public_name = PLAIN
  client_send = ^mas@mylug.org^secret
#  client_send = "${if !eq{$tls_cipher}{}{\
#                    ^${extract{1}{::}\
#                      {${lookup{$host}lsearch*{CONFDIR/passwd.client}{$value}fail}}}\
#                    ^${extract{2}{::}\
#                      {${lookup{$host}lsearch*{CONFDIR/passwd.client}{$value}fail}}}\
#                  }fail}"
#  client_send = "^${extract{1}{::}{${lookup{$host}lsearch*{CONFDIR/passwd.client}{$value}fail}}}^${extract{2}{::}{${lookup{$host}lsearch*{CONFDIR/passwd.client}{$value}fail}}}"

Note that I have commented out the debian additions. It worked.



Sridhar M.A.                                 GPG KeyID : F6A35935
  Fingerprint: D172 22C4 7CDC D9CD 62B5  55C1 2A69 D5D8 F6A3 5935

BOFH excuse #295:

The Token fell out of the ring. Call us when you find it.

Attachment: signature.asc
Description: Digital signature

Reply to: