[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Where's the d@mn GUI?



Chinook wrote:
Kent West wrote:
Chinook wrote:

I've moved up to etch and the 2.6 kernel.  In the upgrade I remember
selecting "dialog" as such was the best at the time.  Now though, I'd
like to get back to KDE (login and sessions).  I was using KDE before
I started the upgrade. I'm sure it's some simple little thing, but I
can't seem to find it in the reeeeams of reference material :-(

"dialog" doesn't have anything to do with X; it is a text-based
"windowing" environment used for asking questions of you during various
stages of configuration.

For example, when you install kdm or gdm, and a text-based "window" pops
up and asks if you want to use kdm or gdm, that's the "dialog" program
that draws that "window". Other programs besides "dialog" can be used,
and that's what you were asked when you chose "dialog", but "dialog" is
probably the best app for most people.

So, your problem with X lies elsewhere.

I'd suggest running "startx", and report any errors that are generated.
You can see the last few lines after X fails to start on the text
screen, which will usually point at the culprit, or you can look in the
log file at "/var/log/Xorg.o.log" (or "XFree86.0.log").

Chances are it's something simple, like failure to start the mouse
(pointer).


You're right (of course :-) , but not simple to me. One time it asked me if maybe I had forgotten libqt-perl, but aptitude said it was installed. Rebooted and tried again and it could not start xserver - said there was a broken dependency with aspell. I tried to install aspell with aptitude, but it could not satisfy a dependency of I forget what now. Loose end there someplace, or a klutz they couldn't protect from himself :-)

Anyway, I had removed gnome (remember a previous issue?) so I am currently in the middle of installing the etch version of that to see if gnome is a go :-P

I remember during the upgrade to etch that I selected Xfree86 where I'm not sure I did back with stable. Could that have anything to do with the problem, and if so how do I go about reversing that decision???

Thanks,
Lee C

PS: I remember I screwed it up so bad the first time with "stable" that I just wiped the HD and started again - don't want to waste that much time again.



OK, I think I narrowed the problem down, but I don't know what to do about it???

At the end of installing gnome

I get the error  dpkg: error processing aspell (--configure)
The script returns 1.

So I look at aspell in aptitude again and it says that for aspell
libaspell15 conflicts with aspell6-dictionary

I can remove libaspell15 (and break some other dependencies) but I can't install aspell6-dictionary because it is a "virtual" thingamajig so it does not actually exist to add %-/

I'm not the only loose end involved,
Lee C



Reply to: