[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: WordPerfect 8.0 (installation)

On Thu, Dec 15, 2005 at 06:04:59PM -0500, Ken Heard wrote:
> 	So it would appear that packages xlibs and xlibs-data supercede 
> 	xlib6g. In fact, the properties list of xlibs_4.3.0dfsg.1-14sarge1 says 
> that it replaces xlib6g(<< 4.0). The xlib6g I was trying to install was
> 3.3.5-1.0.1  I can find nowhere a version of xlib6g >= 4.0.  In any
> event it would be redundant as I already  xlibs and xlibs-data in my
> box. It was consequently unnecessary to do what Mr. Behrens suggested.

("Ms. ...", btw :)

As to your problem: from your first post I seem to remember that the
missing xlib6g essentially was the only problem you had with installing
wp8, so I assume the other required parts would install properly(?)

IOW, now that you've figured out you might not need that package after
all... I'm wondering whether you have tried to install what's available
and isn't conflicting  -- using options like --ignore-depends, etc.; or
by extracting the packages' contents into some temporary directory
(using -X), and then manually moving the required parts to their final
location...).  Maybe, WP would work after that...  Sorry, I can't be
more specific, because I don't really have an idea what's on your CD.

> 	Next, I discovered that the version of xlib6 on the Corellinux CDROM 
> which I was trying to use was not the same as the one Mr. Wiseman was 
> using.  The one I had was 3.3.5-1.0.1; Mr. Wiseman's was 3.3.6-44.  I 
> downloaded that version from Mr. Wiseman's website.  When I tried to 
> install it I got the following response:
> SOL:~# dpkg -i xlib6_3.3.6-44_i386.deb
> (Reading database ... 87476 files and directories currently installed.)
> Unpacking xlib6 (from xlib6_3.3.6-44_i386.deb) ...
> dpkg: error processing xlib6_3.3.6-44_i386.deb (--install):
>  corrupted filesystem tarfile - corrupted package archive: Success
> dpkg-deb: subprocess paste killed by signal (Broken pipe)
> Errors were encountered while processing:
>  xlib6_3.3.6-44_i386.deb

This usually means the package got damaged somehow (while downloading,
or so), so the contents simply cannot be unpacked (not sure though, why
dpkg considers the corrupted archive a success ;)

> (...)
> 	It is very much of a disappointment that I cannot seem to be able to 
> use WP8.0  It makes the claim that Debian is about choice sound hollow.
> 	There is now another possible option: WINE.  Now that a beta version 
> 	of WINE is out, I may be able to install WP 12 using it.

That would probably be the best option, if you get it to work -- at
least you'd then have a recent version of WP.  My personal experiences
with WINE have always been somewhat disappointing, though... however,
my last try was more than a year ago.  The typical scenario was that
99.9% worked fine, but the remaining 0.1% were rather annoying,

Well, if all else fails, and you don't feel like giving up yet, you
could try to install the whole stuff into some chroot environment.
That would avoid any conflicts with whatever else is installed, and
should basically always work (with a few restrictions, as mentioned

Actually, I had done exactly this way back in 2001, and it worked fine.
The only problem I had was that I somehow didn't get printing to work
directly to the printer (don't remember exactly what the problem was),
so I simply printed "to file" using some builtin PS driver, and then
spooled the PS file using lpr from outside of the chroot (not a big
issue, for my taste.).  (Later, I stopped using WP altogether, because
I somehow do prefer batch formatting tools like latex, and generally
no longer have much document composition to do...)

In theory, I could send you a slightly re-packaged tarball of that
entire wp8 chroot directory, in case you're interested [1].
I just unpacked and ran it again -- still seems to work... the 'about'
box says it's version 8.0.0078.

The only problem is that it now seems to want a license number (which I
of course no longer have -- actually, I don't remember ever having had
to enter one, but my memories may have faded). IOW, it claims it will
quit working after a trial period of 90 days...  But well, maybe there
is a license number on your CD or book cover.

Another option would be that you somehow make the contents of your CD
available to me for download, and I'll try to setup a chroot install
from the very WP version that you have.  In principle, you could of
course do that yourself as well.  However, in case you don't have much
experience setting up chroot environments, I'd rather offer to simply
do it myself (instead of describing the steps, and elaborating on all
potential difficulties you might encounter -- sorry for the laziness).

Anyhow, before you say yes! (or no), please note that

* you'd have to start WP via sudo (because of the chroot -- WP itself
will be run under your regular UID).  This probably isn't a big issue,
if you simply want to use it on your private box.

* all documents will always have to be placed somewhere below the
chroot directory -- this means that from outside of the chroot, they'd
be accessible under something like /path/to/chrootdir/home/user/docs/*,
when you save them to /home/user/docs/* from within WP.

* you'd have to run your X server without the "-nolisten tcp" option,
which is commonly recommended nowadays (for security reasons).  IOW,
the X server has to listen on its regular TCP socket (port 600x) -- the
X server's local (unix domain) sockets won't work.

* printing will likely only work as mentioned above (though I might
look into that issue again)

* you'd have to trust me not to package any trojans or other malware
(not saying that I would, but obviously anyone could make that claim...)

Just let me know, if that still sounds interesting...


[1] the size of the tarball is roughly 20 MB.  I'd probably have to
send it via mail attachment, because I currently don't run a publicly
accessible webserver or somesuch (and I don't plan on setting up one
for just that purpose...)

Reply to: