[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Un-bootable kernel due to bad initrd (Solved)

Karsten M. Self wrote:

on Wed, Dec 14, 2005 at 01:53:36AM +0200, Andrei Popescu (andreimpopescu@yahoo.com) wrote:
This is unstable ... indeed it is :)

This seems to be |Bug#343042

|Just to summarize:
i just did an '#aptitude upgrade' and my kernel 2.6.14 got upgraded (and probably yaird allong the way too). Due to the yaird mentioned above the created initrd image is bad and Debian won't boot. Because it was a minor kernel upgrade i don't have a backup kernel...won't do *that* mistake again :)

Is it possible to recover from this? All i have is a Knoppix CD (the windoze doesn't count :D) and another machine with stable on it (kernel 2.6.8). I don't want to repair this the M$ way (format c:)

Boot Knoppix.  Mount your installed root partition.  Chroot into it.
Mount any additional partitions underneath it.

You're now effectively in your installed system.  Install / remove /
configure packages as necessary, rebuild your initrd, etc.


Actually i had already tried this, but then i didn't know yaird was the culprit so it failed. It worked now, after purging yaird and solving another error (/dev/null: Permission denied) For archive readers: before chrooting you need to mount you / partition avoiding Knoppix' fstab
#mount -o rw /dev/hda4 /mnt/hda4
This is explained on Knoppix' site.

thanks for the impulse though, i was just about to give up. i had no ideea if it is even possible to recover from this (without guru knowledge :D ), but linux amazed me *again*


Reply to: