[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: 2.6.14 image will not install (SOLVED)

>The new mkinitrd.yaird fails. Anyone else have this problem, fixed it?

This new yaird stuff uses files in new directory /etc/yaird

The Default  conf file needs be edited BEFORE attempting the install :-)

1. I changed cpio to cramfs -- this means I want an initrd rather than 
something else. :-). This was probably already being done by the install 
scripts command line.

2. I pointed the MOUNTDEV to the root fs device in /etc/fstab. If you do not 
do this, then who knows what you get! (Note that all such options here take 
your "target" followed by "/mnt")

3. /etc/fstab had that device mounting as ext3,ext2 as a fallback. Since the 
mkinitrd.yaird modprobs based on this substring, this produces an error. Ext3 
works so the ,ext2 was deleted. Now, everything flows.

I did not touch any of the other templates in /etc/yaird. Now, I'll see what 
happens if I try to boot it .....

BTW: Who is yaird? Davidb might want to be in touch :-)

Reply to: