[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: drm and radeon module load problems

On Wed, Oct 05, 2005 at 10:46:03AM +0200, Lubos Vrbka wrote:
> hi guys,


> i'm running testing on my amd64 and i updated to kernel 2.6.12 (via 
> dselect). i selected to compile drm and dri as modules (i want hw 
> acceleration of my ati radeon x600 card). compilation went fine, the new 
> kernel works ok. however, i cannot get hw acceleration to work.
> the 2 modules above apparently don't work. drm complains about not being 
> able to allocate memory
> Error inserting drm 
> (/lib/modules/2.6.12/kernel/drivers/char/drm/drm.ko): Cannot allocate memory
> radeon complains about unknown symbols in module, dmesg reveals the 
> followinG:
> radeon: Unknown symbol drm_open
> radeon: Unknown symbol drm_fasync
> ... and so on

What does dmesg say about agp?

> on web i found out that this could be caused by missing support for 
> /dev/agpgart in kernel. however, i cannot select it in menu/xconfig. my 
> .config file contains
> so the support should definitely be present. where's the 
> CONFIG_AGP_AMD64 coming from? i couldn't find any switch in the 
> menuconfig that'd control this. also, is CONFIG_AGP selected 
> automatically? the strange thing is that the same setup (i hope i didn't 
> miss anything) worked fine on 2.6.11.

In my AMD64 the AGP comes from:
Device Drivers --->
  Character devices --->
    /dev/agpgart (AGP Support)
      AMD Opteron/Athlon64 on-CPU GART support

If I have
Processor type and features --->
  IOMMU support
selected, then the /dev/agpgart is automatically selected, and I don't
have the 'AMD Opteron/Athlon64 on-CPU GART support' available.

> i was also told to compile agpgart support as a module, as well as 
> support for my chipset CONFIG_AGP_chipset=m. is it possible that this 
> via agp chipset isn't supported in 2.6.12?

Did you mention which chipset you have, maybe I missed it. Anyway I
don't think that a VIA chipset wouldn't be supported. Even my K8T800Pro
worked with 2.6.12 and lspci lists it in 2.6.14.

You can always try the 'agp_try_unsupported=1' option (if you use agp as
a module). If the agp is in the kernel, give that as a kernel parameter.

Once again, check what dmesg says about agp.

> i guess this shouldn't be amd64 related, so i'm posting here... if i'm 
> wrong, please let me know :)
> thank you for any hints. regards,

I don't know what might have changed between 2.6.11 and 2.6.12
concerning the agp, sorry :(

> -- 
> Lubos
> _@_"

:r ~/.signature

Attachment: signature.asc
Description: Digital signature

Reply to: