[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem using Canon SD400 on Debian Sarge

Sayantan Sur wrote:
> On 10/3/05, Henrique de Moraes Holschuh <hmh@debian.org> wrote:
> > On Mon, 03 Oct 2005, Sayantan Sur wrote:
> > > As soon as I plug the camera in, for a brief period it is reported by
> > > `lsusb' (from usbutils package). But after a few seconds, the device
> > > dissappears from lsusb!! However, it is always to be found in
> > > /proc/bus/usb/devices.
> >
> > Try lsusb as root.  If it shows up, it is just braindamage happening, with a
> > race condition on USB plugin just to make sure you know that whomever is
> > responsible for it really needs to get his act together.
> >
> > Track down whatever is screwing up with /proc/bus/usb permissions and you
> > will have the culprit.
> Thanks a lot! This worked. There is definitely brain damage happening
> ;-) Apparently, if I run lsusb as root, everything is just fine.
> However, as Tom else pointed out on the list, it is not accessible as
> a Mass Storage Device. Now, if I use gphoto2 as root, then everything
> is just hunky-dory.

You may still have to add your user(s) to the camera group....and then
that usually requires the user to log off and then on for the change to
take affect.


Reply to: