[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem using Canon SD400 on Debian Sarge

On 10/3/05, Henrique de Moraes Holschuh <hmh@debian.org> wrote:
> On Mon, 03 Oct 2005, Sayantan Sur wrote:
> > As soon as I plug the camera in, for a brief period it is reported by
> > `lsusb' (from usbutils package). But after a few seconds, the device
> > dissappears from lsusb!! However, it is always to be found in
> > /proc/bus/usb/devices.
> Try lsusb as root.  If it shows up, it is just braindamage happening, with a
> race condition on USB plugin just to make sure you know that whomever is
> responsible for it really needs to get his act together.
> Track down whatever is screwing up with /proc/bus/usb permissions and you
> will have the culprit.

Thanks a lot! This worked. There is definitely brain damage happening
;-) Apparently, if I run lsusb as root, everything is just fine.
However, as Tom else pointed out on the list, it is not accessible as
a Mass Storage Device. Now, if I use gphoto2 as root, then everything
is just hunky-dory.

> > Oct  3 21:50:40 localhost usb.agent[7405]:      libgphoto2: loaded successfully
> Ah. This means hotplug is probably the one to blame for the race condition.

Looks like it. Can you tell me what should I do to accurately describe
(collect info) the race condition to the developers of gphoto2/usb


> --
>   "One disk to rule them all, One disk to find them. One disk to bring
>   them all and in the darkness grind them. In the Land of Redmond
>   where the shadows lie." -- The Silicon Valley Tarot
>   Henrique Holschuh
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


Reply to: