[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian Kernel 2.6.12 and parallel port problems.


I'm running Debian Etch (testing) and after upgrading to the debian
kernel version 2.6.12-1-686, my parallel port printer no longer seems
to work. What I mean is that Debian doesn't seem to be able to
communicate with it. Everything is physically plugged in: power and
parallel cable.

After running lsmod, I find that the modules lp, parport, and
parport_pc are all loaded. I don't believe I need any other modules do
I? My boot log, /var/log/boot, says that parport_pc was loaded

I'm using CUPS and my printer is an HP LaserJet 5L. I use the
foomatic/ghostscript driver ljet4 (as recommended by
www.linuxprinting.org), along with a PPD file acquired from
www.linuxprinting.org. When I view the printer at
http://localhost:631, it says "Device URI:
parallel:/dev/unknown-parallel0" even though /dev/lp0 exists. When I
try to print a test page from http://localhost:631, it says "Printer
not connected; will retry in 30 seconds..." on http://localhost:631.

NOW, here is the important part. after sending a print command, I
check dmesg, and 3 new lines are outputted:
     parport0: FIFO is stuck
     parport0: BUSY timeout (1) in compat_write_block_pio
     DMA write timed out

Unfortunately, I have no idea what to do with this information. But I
do know that my printer worked fine using CUPS and the same driver on
an older 2.6.8 kernel. I suppose it could be a bug, in which case I
should probably report it to the Bug Tracking System. But I don't know
which package I should put it under, since there are linux-image-2.6,
linux-image-2.6-686, linux-image-2.6.12-1-686.

Anyway, I've tried to be as informative as I can, but if you need more
information I can give it to you. If anyone can help me, it would be
greatly appreciated.


Reply to: