[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Making a live cd (initrd / kernel panic)

On one machine I created a chroot using debootstrap, and put grub
(stage2_eltorito) into it, but I think I'm having trouble with my

When I tried just installing the kernel, by default it automatically
tried to run mkinitrd, but I think because I was in my chroot (and not a
real device) it failed.  So before installing the kernel, I installed
the initrd tools, and modified the mkinitrd ROOT variable to be blank.
Now the kernel installs (without an initrd).

So I used (bootcd) mkinitrd-cd to create the initrd inside the chroot.
And then mkisofs and cdrecord the whole thing.

On our target system, I boot to the cd, grub loads, and the kernel
appears to load, but then panics...  Cannot mount root fs on

I'm not sure, but I'm afraid that (3,1) coorisponds to the boot
partition of the first machine (where the initrd was created)...

Any clues?  Thanks so much for your help

Reply to: