[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

several problems



Hi people,

I have just migrated from my old win machine to a new opteron smp debian box. Cause I have a quite limited knowledge about linux, I ran into some difficulties, esp. when it comes to running a 64bit smp system in 32bit compatibility mode.. (I want to use it as a workstation and have a good choice of apps).

The story:
- installed sarge with 2.6.8 i386 kernel
- installed 2.6.11 amd64-smp with synaptic

Couldnt resolve following problems:
- nvidia drivers for the board integrated sound device..
- couldnt install the firestarter firewall or use the kde firewall due to some ip-tables problems
thou I tried to search for a solution, I wasnt able to find any

******** nvidia problems:

During the make of the drivers, i get crosscompile errors when trying 64bit drivers

/tmp/selfgz4740/NFORCE-Linux-x86_64-1.0-0301-pkg1/nvsound/main/nvalinux.c
cc1: error: code model `kernel' not supported in the 32 bit mode
make[4]: ***
[/tmp/selfgz4740/NFORCE-Linux-x86_64-1.0-0301-pkg1/nvsound/main
/nvalinux.o] Error 1
make[3]: ***
[_module_/tmp/selfgz4740/NFORCE-Linux-x86_64-1.0-0301-pkg1/nvso
und/main] Error 2
make[2]: *** [modules] Error 2
-> Error.
ERROR: The NVIDIA kernel module was not created.
ERROR: Installation of the audio driver has failed. Please see the
file '/var/log/nvidia-nforce-installer.log' for details. You may

when using the 32bit drivers, the nvidia installer terminates saying that i got a 64bit system so i should use the 64bit drivers.
trying to find a solution with nvidia tech support, but sofar we've been exchanging mails for about 10 days without a result. any ideas? (please keep in mind, i'm definitely a linux newb)

************ iptables problems
when trying to setup rules using the nice gui apps, i get either

iptables v1.2.11: can't initialize iptables table `filter': Module is wrong version
or
iptables v1.3.3: can't initialize iptables table `filter': Bad file descriptor

depending on the version of iptables used. i read somewhere that the bad file descriptor error happens on pure 64bit systems and can be removed by installing the apropriate drivers with --force-all but that didnt really help in my case, i assume that its due to me running 32bit debian on a 64bit-able machine. any clues?

************* a bit more of questions:
the reason why i wanted to install the firewall was that after running the linux box for a few days, my gaim suddenly stopped working with my icq accounts = during normal operation i have been disconnected because I assumedly logged in from another location. my passwords got changed and sicnce that i'm blocked of using icq. i am unsure if this is a problem on icq's side or mine, i had problems with pwd generation from their site (keeps returning errors or doesnt answer at all). i suspected some trojan or some tampered dns. i changed the dns servers, ran the f-prot antivirus and wanted to install the firewall but ended up with the problems described above. has any1 encountered similar problems? is there anything more i can do to tighten the security? can anyone give me some tips?

thanks, Pavel



Reply to: