[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Win 9x Clients FAIL to Connect after upgrade to Sarge!


On Wed, 7 Sep 2005, Clive Menzies wrote:

> On (06/09/05 16:08), Lawrence Houston wrote:
> > Debian USERS:
> >
> > After upgrading from Woody to Sarge I find Windows 9x Client are unable to
> > Browse/Connect to Samba Shares!!!  Windows 2000 and Linux Clients are
> > working as they had before the Upgrade from Samba 2.2.X to 3.0.X, but the
> > Windows 9x Clients no longer see anything within their Network
> > Neighborhoods, fail on searches by Hostname and attempts at Network Drive
> > Mounts???
> I have a number of sarge servers running Samba 3.0.14a-3 and serving a
> heterogeneous client base including Windows 98 and 98SE clients.  It
> worked out of the box (for MacOSX clients, I had to explicitly share
> users home directories in smb.conf).

To my surprise Windows 9x Clients were connecting just fine to Shares on a
"clean" Sarge Installation (VMware) and to the Router with the smb.conf
copied over from the "clean" Sarge...  The remnant left over from my Woody
to Sarge Upgrade was the "questionable" use of "socket address"!!!
Originally my smb.conf included the following:

        bind interfaces only = True
        interfaces =
        socket address =

Configurations which worked included adding the Local Interface:

        bind interfaces only = True
        interfaces = eth0 lo
        socket address =

Or excluding "socket address" all together"

        bind interfaces only = True
        interfaces = eth0 lo

I had been using this same "bind interfaces only" and "socket address"
Combo for years, therefore it will require someone more familiar with
Samba's inner workings to explain why this problem appeared only after
upgrading from 2.2.X to 3.0.X and why it effected ONLY Windows 9x Clients
(Windows 2000 and Linux Clients could still connect)???

The intent with my Original Syntax was limiting Samba's Services to the
Private LAN Interface ONLY, with the WAN Interface being excluded...
With Samba 3.0.X what would be the "correct" Syntax to accomplish this???

Lawrence Houston  --  (debian@greenfield.dyndns.org)

Reply to: