[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't recover sound

Le Mercredi 07 Septembre 2005 05:37, Victor Munoz a écrit :
> Hello.
> Sometimes I can't hear any sound (xmms, mplayer, play), getting things like
> 'Device or resource busy'. This happened in woody, now in sarge, sometimes
> in sid, and everytime it happens, I do a Google search to try to find a
> solution smarter than rebooting, but never find an answer, so I have to
> reboot.
> So the question is: How can I recover sound in this situation? Yesterday it
> happened, for instance. There was no xmms, mplayer, play, skype, realplay
> or whatever I could remember involving sound running in the background. I
> don't run esd. But still, I could not play any movie or hear any sound from
> xmms. I tried removing/reloading sound modules, but everytime I tried, it
> complained that the module is being used and cannot be removed. There
> doesn't seem to be a rmmod -f option.
> Is there a way to know which program is using the sound modules, so
> I can kill that, or any other way to recover a 'clean sound state' without
> rebooting? There should be, but Google has not been my friend, probably for
> my inability to make the right question.
> Regards,
> 					Victor

well, i assume you're running kde.
in that case, you can start kcontrol, and find the sound and multimedia. There 
in "sound system" you can try to unselect and reselect "enable sound system", 
then click the "apply" button

however, that's only a temporary solution as it is quite boring to do it 
you might try to use another "audio device" in the Hardware tab

Reply to: