[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

install troubles


I've just today, tried to install the 14 disk set is 3.1 (sarge) onto 
a drive in a test box, but after the one disk was done, it asked to 
be rebooted rather than asking for more disks, this despite my using 
the 'expert26' install argument.

So I ran aptitude when it was rebooted since the basic install doesn't 
put much on, leaving a bare bones system only.

I spent the majority of the day wandering around in aptitude, both 
looking for the everything option or trying to find both perl-5.8.x 
or enough x11 to get a gui running, without finding either.

So I brought the disks back up here to this machine and ran this 
script against all 14 disks without getting any output indicating I'd 
actually found either:
mount -t iso9660 /dev/cdrom /mnt/cdrom
# so I can see it, then
tree /mnt/cdrom
sleep 2
# grep for it
tree /mnt/cdrom|grep x |grep core
tree /mnt/cdrom |grep perl-5.8
umount /mnt/cdrom
eject /dev/cdrom

So then I made an MD5SUM file in the directory full of the 3.1 iso's, 
and I am checking each disk's md5sum against the .iso's to see if I 
left out a cd in burning them.  But so far, everything has matched.

I got the same impression that python was missing major pieces also.

atp-get update seems to go get the database again, and networking 
seems to be ok, but an apt-get install perl reports 'there is no 
candidate for perl'.

Humm, I'd assumed that the first disk was already entered into the 
aptitude database, but thats where perl (and python-2.3 at least) 
seems to be.  So how do I rectify this?  Man aptitude seems crypticly 
quiet on that subject.

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
99.35% setiathome rank, not too shabby for a WV hillbilly
Yahoo.com and AOL/TW attorneys please note, additions to the above
message by Gene Heskett are:
Copyright 2005 by Maurice Eugene Heskett, all rights reserved.

Reply to: