[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't get Intel 82915G on-board graphics controller to deactivate the monitor.

On Thursday 28 July 2005 09:26, Adam Funk wrote:
> My computer has on-board video which `lspci -v` reports as follows:
> 0000:00:02.1 Display controller: Intel Corp. 82915G Express Chipset
> Family Graphics Controller (rev 04)
>         Subsystem: Asustek Computer, Inc.: Unknown device 2582
>         Flags: bus master, fast devsel, latency 0
>         Memory at cfe00000 (32-bit, non-prefetchable) [size=512K]
>         Capabilities: [d0] Power Management version 2
> I tried using the i810 driver but couldn't get it to work ("No screens
> found" etc.).  Using the vesa driver everything works fine *except* that
> the screen won't go blank when the computer is inactive.  (I know the
> monitor is capable of handling this, since it used to do it correctly
> with a different computer and RedHat.)
> My XF86Config-4 file currently contains the following stanzas.
> Section "Device"
>         Identifier      "Generic Video Card"
>         Driver          "vesa"
> EndSection
> Section "Monitor"
>         Identifier      "LA702U"
>         HorizSync       30-70
>         VertRefresh     60-160
>         Option          "DPMS"  "on"
> EndSection
> I would especially appreciate any suggestions for getting this graphics
> card with the vesa driver to drop the monitor signal after a period of
> inactivity.  Alternatively, I'd be interested in debugging advice for
> getting the i810 driver to work (it's supposed to be the correct one).
> http://support.intel.com/support/graphics/sb/CS-010512.htm
> --
> Thanks,
> Adam

Hi Adam,

It seems a lot of people aren't too thrilled with the i810 driver in Xorg.  
I had a problem of direct rendering being on but alternately giving me 300+ 
fps on glxgears and then 30 fps after logging out and logging back in.

Anyway, after much searching, I found this link: 
http://www.fairlite.demon.co.uk/intel.html  You might try downloading that 
driver, and see if it fixes your problems.  It's worked for me, and a few 
other people as well.

Note that for X, use the i810_drv.o driver (called i810 in the config file), 
but in your kernel, load the i915.ko driver.

If you want, post the relevant portions of your log file, and we'll see if 
we can't figure out what's wrong.

Best of luck,
Justin Guerin

Reply to: