[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

upgraded, now unbootable: lacking a boot-menu.b file?

Hi. I can't boot after upgrading to sarge from woody on an older i386 (pentium II, actually) with a custom kernel. I followed all the instructions (I think! :), and it used to work until the first reboot after the upgrade. It gets as far as the memory check, says "MBR", then instead of LILO it just says "LI" and stops.

Googling in many ways for this issue suggested that where my lilo.conf file points to a "install=/boot/boot.b" file, and /boot/boot.b is a symlink to "boot-menu.b" (though it could also point to "boot-text.b" etc I guess), but I see that I have no boot-menu.b present. I tried using "tom's root boot disk" and copying in various files like a boot.b from another system etc., but they fail with different error messages like "Map segment is too big" when I run lilo, making me think the lilo on that boot disk & other "boot.*" files I copied to my system's boot directory were not compiled w/ the same version of libc or something.

My debian rescue floppies don't seem to be any good; they either ask for another RAM disk or get other bootup errors; maybe they were too old. So my next shot was to run lilo from "tom's root boot disk, but that copy of lilo doesn't seem compatible version-wise or the necessary boot.* files aren't present on the HD which now is (mostly?) a debian sarge system.

Did I somehow fail to get a Sarge-style copy (newer) of lilo.conf by making a bad choice during the upgrade perhaps, and my old lilo.conf is inadequate? Or is there somewhere I can get a sarge-compiled copy of boot-menu.b (or any of the files like boot-test.b etc)?

Do I have many choices (hopefully) short of reinstalling from scratch? I think it's just whatever lilo does, if I can figure out how to get there....

Any advice much appreciated!! Many thanks in advance...


Reply to: