[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Fwd: Re: Sound problem: apparently I don't have the alsa modules up yet after all

Let me preface this post with an apology for inappropriately sending to private emails without checking rather than just directly to the list. I'll make an effort to be more careful in the future.

I have now got the kernel updated to a -686 thing, and have the corresponding modules, ... it seems I still have to figure out the alsa file stuff from the configuration page. Nothing works yet, but I do have a mess of configuration stuff to check (http://linuxmafia.com/faq/Debian/alsa.html#sargestock). Rebooting with the new kernel and modules got the lsmod listing with snd-* files, but no sound yet. I'm trying to follow the instructions on this link: (http://linuxmafia.com/faq/Debian/alsa.html#sargestock). I seem to have everything in order. I've attached my /etc/modules.conf file in case that is of interest. I would sure appreciate further feedback on this. I also did the chmod a+rw setting specified on that instruction page. I know this is a drag guys, but I'd appreciate more feedback if you can stand it.

Sincerely, Xeno

>>> I've got three jacks together on my T3985 (Celeron system with all the

stuff in the motherboard):

  My new debian system doesn't relay any sound to my speakers.  I've
tried two sets of speakers, and both sets work on my other system's cd
drive jack.  The sound plug area in the back of my new system has three
holes, and the "line out" output is the same green plastic as the male
part on the wire to the speakers.  The other two holes say MIC (orange)
and "line out" (light blue).  Another system I recently tried to
linux on also could not put sound out and it also had the same three
jack holes (apparently that's popular now?).  I wonder if the driver
expects only one or two holes and is confused by seeing three?

I've looked at some postings about problems like this, and none
seems to
match mine exactly.  One said the guy could play on root, but I tried
that with cdplay start on this, and it still didn't make noise.  I'm
sure what else to look for.

I think the special files are /dev/dsp*,  and I changed these to
protection 666.  I run CD Player
to test the sound and it runs and identifies a Duke Ellington CD, but
the sound just don't come out even though it shows the CD playing.

I'm not sure if the drivers for audio are all there.  The only thing I
see is something called "soundcore", but perhaps that's all that's

Dear Xeno,
I'm running Debian Etch and have a similar 3 plug arrangement in back.
One for the mike and sound left, sound right. It might help if you gave
us a bit of info on your system. Which Debian are you running? Have you
installed alsa (lots of postings about how to do that). The more info
you give the easier it is to help.
I'm running Sarge, and I just installed it this weekend.  I did
install alsa, but I don't know if the test program I'm running is an
alsa program.  It's the "CD Player" in the multimedia pulldown, which
seemed like the simplest one to try (and there is another thats a
command line one I

Xeno Campanoli, xeno@eskimo.com, http://www.eskimo.com/~xeno
Pride before justice      equals destabilization.
Power before truth        equals destruction.
Profit before environment equals death.

Reply to: