[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ALSA: no sound, no error! -- Solved

[KS] wrote:
> Colin wrote:
>>[KS] wrote:
>>>I did that too. After reboot, I can hear noise when I do cat
>>>/dev/urandom > /dev/dsp. But the sound stops working as soon as I login
>>>to KDE! I notice that after I log into KDE, I have to stop alsa, remove
>>>the file from /var/lib/alsa and start alsa again to get sound working
>>>again. At present, sound is working perfectly, but /var/lib/alsa has no
>>>file in it. Does that make any sense?
>>I'd disable KDE sounds completely.  They seem to get in the way for me all
>>the time.
> Well, I don't use all the KDE sounds that much. But the real concern is
> why sound is not working when logging on into KDE (maybe I should also
> check what happens when I login to Gnome). Earlier it was working fine
> with allt he sounds in KDE if they were enabled. So I think there is
> still something wrong which needs to be taken care of.

After more investigation I found out that KDE was playing spoil sport.
When I loged in with Gnome, sound worked. After that when I tried
logging in with KDE, sound didn't work. Thus KDE login was causing some
problem. I removed all the KDE settings from my account and tried
logging in. Walla! Everything worked as expected. KDE login audio
greeting was back as earlier and other sounds are working fine.

The KDE problem has happened the second time. I have had to remove the
KDE settings to get sound working. I am still confused as to what causes
this corruption or when it happens.

So, for making the sound to work I had to do the following:

1. ~$ /etc/init.d/alsa stop
2. ~$ rm /var/lib/alsa/asound
3. ~$ /etc/init.d/alsa start

4. Log out of KDE and remove all KDE settings

Thanks to everyone who helped.

Reply to: