[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Disk Mirroring in Sarge howto

On 6/14/05, Rhomboid <rhomboid@globalmegahypernet.com> wrote:
> I just tried to install Sarge yesterday with RAID (md) from the initial
> setup on a machine. I tried RAID-0 and RAID-1 and both times the
> installation failed on grub-install. It just hung. The third time I let
> it sit for about 5 hours and when I got home it was still hung. LILO
> failed as well and couldn't find hda (no such device).
> AMD Athlon 1.2GHz (tbird)
> 512MB PC2100
> Nvidia GF3 64MB
> Asus A7M266
> 2x WD JB 40GB (hda/hdb, tried RAID on these, using md)
> 1x IBM 16GB (hdc, used for swap and /var)
> Adaptec aic7xxx (onboard SCSI)
> Plextor SCSI Ultraplex CD
> Seagate SCSI Scorpion DAT 20GB
> Intel EEPro 100
> Tried setting both WD drives bootable at one point, always selected MBR
> for bootloader installation. I know it may have been "better" to put one
> half of the RAID on the other controller but this was just an experiment
> to see if it would even work on initial install.
> System installed just fine later without RAID.

Hi Rhomboid,

I fllowed these steps to get it right

 If you want to install Sarge with RAID-1, create identical
partitions on both disks and tell Sarge you want to use them as
Physical Volume for RAID.  Then go into the Sarge Configure software
RAID menu and create MD devices (RAID volumes) -- you will be prompted
for the partitions to use for each RAID volume.

Once the RAID volumes are created you can continue specifying mount
point, FS type, etc for each volume exactly as you would for a normal
disk partition.

I am not sure if GRUB is on both the DISKs

DID you mark the volumes active of bot the disks while creating RAID volumes??

the RAID works fine

# cat /proc/mdstat
Personalities : [raid1]
md2 : active raid1 hdd3[1]
      4883648 blocks [2/1] [_U]

md3 : active raid1 hda5[0] hdd5[1]
      489856 blocks [2/2] [UU]

md4 : active raid1 hda6[0] hdd6[1]
      1951744 blocks [2/2] [UU]

md5 : active raid1 hda7[0] hdd7[1]
      2931712 blocks [2/2] [UU]

md6 : active raid1 hda8[0] hdd8[1]
      2931712 blocks [2/2] [UU]

md7 : active raid1 hda9[0] hdd9[1]
      23486912 blocks [2/2] [UU]

md1 : active raid1 hda2[0] hdd2[1]
      1951808 blocks [2/2] [UU]

md0 : active raid1 hda1[0] hdd1[1]
      489856 blocks [2/2] [UU]

unused devices: <none>

thankyou so much

kind regards


Reply to: