[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Alsa not working after reboot

Having been a fairly long-time Slackware user, since 8.1, and being
somewhat unhappy with some compatibility problems with Gnome apps and
that distro, I decided to see if Debian would work for me.  I don't
have high-speed internet access and so used a work computer which I
have access to periodically to download and burn the first two discs
of Testing.  This seemed a solid place to start and I was confident
that two discs would get a working system up.

I was not surprised to find that basically I was right, though
surprised at some of what was left off of these two discs, eg. alsa, X
headers and libraries, emacs, etc.  But, overall, things went well and
after tinkering about with the installation I soon got a working
system with the basics in place.

After downloading and installing the alsa-1.0.8 packages I ran
alsaconf and had the sound up and running.  However, I discovered
later that if I rebooted the sound never reloaded and I had to run
alsaconf again.  This had happened to me some time back with Slack 9.1
and I managed after some work to get it going, but I cannot really
recall how.  I fear that with Debian I am unsure of where to start.
The modules.conf file is a bit of a shocker for me as it is nothing
like that of Slackware, and has a great deal more going on.  I cannot
really tell if it has what I need in it at all.  The
/etc/modprobe.d/sound file, which I am not familiar with at all, is
there and has a reference to my card, es1688.  Other than that I
haven't a clue what it does and cannot be sure what it should have in

I have noticed that at the end of the boot process a brief reference
to alsa is seen, and something along the lines of "no modules loaded."
And in fact nothing is.  An lsmod shows nothing related to snd at all,
and there is no mixer to adjust.  So my situation is not a muted card
or pcm but in fact a total absence of sound.  Only running alsaconf
again with each boot will make sound usable.  I have tried a number of
google searches only to find numerous muted cards and loaded modules
without sound, but can't seem to locate any with no modules being
loaded at all.  Is there a step or action after alsaconf which will
make this permament and reload the modules with each boot?  Am I
forgetting or overlooking something stupidly obvious?


Reply to: