[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Posted Three Times - No Responses



I have always received great help from this list in the past but I have had no responses at all to my current problem. Perhaps hundreds of people have looked at the postings but had no ideas as to how to solve the problem. Perhaps everyone is too busy getting ready for the release of Sarge. Perhaps the answer is so obvious that I should have solved it myself long ago.

The problem: Every time I must shut down the system it locks up when it tries to disconnect my Sony USB dvdrw drive.

The Postings:  May 17 - USB dvdrw mount point Woes
                       May 22 - kernel-2.6.8  USB problem
                       May 31 - Oops when Sony USB dvdrw disconnected.

As noted in these postings I am using 2.6.8 kernel complied from the latest kernal-source-2.6.8 (so recompiled yesterday after a apt-get dist-upgrade). I am not using discover or discover1because discover provides no mount point and discover1 provides /dev/sr0 which only allows me to mount the device to read data cd's. Without these the device is assigned /dev/sg0 and works perfectly with both cdparanoia and cdrecord. Hotplug allows me to connect and disconnect other usb devices but not the Sony DRX-510UL USB dvdrw drive.

I have no trouble using the device as a USB1 (low speed device) with a 2.4.26 kernel - perhaps because I have append="hdc=ide-scsi" in its lilo stanza. I have omitted this in the stanza for the 2.6.8 kernel as my understanding is that it is no longer required. With out the append="hdc=ide-scsi" line in the 2.6.8 kernel stanza cdrecord -scanbus finds the Sony drive as 0,0,0 and cdrecord -scanbus dev=ATA finds my cd drive and my cdrw drive as 1,0,0 and 1,1,0.

As noted in one of the previous postings I have searched the archives and found some postings which seemed related to this problem but no solutions that worked for me. If there is something I have missed my feelings wont be hurt if it is pointed out forcibly - I just need a solution.

Tom George




Reply to: